Trouble with AVRDUDE

Hi Everyone

I am trying to write a bootloader to my Ardunio R3 connected to a USBASP Programmer, Im using AVRDUDE 6.2 on my macbook pro.When i issue the command to check a blank ATMEGA8 chip: avrdude -c usbasp -p m8 I get initilization error rc=1.

I tried a friends Adafruit Programmer and issued the command avrdude -c usbtiny -p m8 connected to the Ardunio R3 it works and im able to program the boot loader.

If i put the Atmega8 chip back into programmer once the bootloader is programmed onto it, with the usbasp, and enter avrdude -c usbasp-p m8, it checks the chip and says its ready to accept commands, and i even sent the hex file over to it via AVRDUDE.

so my question is why i cant program the boot loader using the USBASP, avrdude -c usbasp -p m8.

I'm new to this so any help would be grateful


Chinese USBasp have old firmware probably, there is required to short the JP3 - slow SCK for raw chips.

Hi There thanks for trying to help me, this is the one I bought

As im a beginner can you please explain how I short the JP3 ?


The JP3 is next to USB connector (visible nicely on the picture - the link you've sent). The best way is to solder pins and use the jumper. For temporary use, you can try to connect holes with piece of soft copper wire.

I tried that and it worked a treat wow was amazed, just want to say thank you it saved me pulling all my hair out, shall I keep the jumper on all the time ?

thanks once again

Great. Yes, you can use it with the jumper, You can also update newer firmaware in the USBasp which solve this problem and you will not care about JP3.
I'm using usbasp-1.06-alpha. Here is a link GitHub - bperrybap/usbasp at 1.06-alpha It is bperrybap's modification. He is also a member on this forum.