Trouble with DFU Programming

Hey guys, Im working on a midi project and had to switch the firmware on my Arduino Uno to the MocoLUFA.hex using the terminal commands.

The code didnt work and now that I am trying to switch the Arduino back to its original .hex Im getting "error parsing the line."I was told this is probably because the firmware I downloaded was corrupted so I tried redownloading (from the arduino github) and downloading from other sources but I’m still getting the same error.

Im new to programming so I could just be making a very simple mistake; can someone walk me through how to get around this issue. My solution right now is to buy a new Arduino whenever the code doesnt work so I have 4 boards that are stuck with unusable firmware and I’d really like to be able to use them again lol.

thanks in advance!

Here is the tutorial I am following http://www.instructables.com/id/Arduino-Touch-capacitive-Midi-keyboard/ as well as http://www.arduino.cc/en/Hacking/DFUProgramming8U2.

I am using Mac OSX Lion and Ableton Live 9 if that matters. I can get the board to show up as a Midi/MocoLUFA device in Ableton but it wont respond to any of the touch pads so I'm guessing the problem is with the code itself.

Also, If anyone is familiar with Ableton, Midi, and DFU programming and can spare some time to answer some of my questions please DM me.