Trouble with ethernet shield and HID reader

Good day guys. I have a project where I use a HID Card Reader and a Real time clock to get the time in. So that part works great my problem is when I begin my ethernet shield the reading from the HID Card Reader is altered but when I comment that part out the reading is correct.
I get the reading from the card reader by using the interrupt pins and analog pin for the real time clock.
http://www.e-gizmo.com/KIT/ethernet%20shield.html this is the ethernet shield and I use the EtherCard library.
Any suggestion would be great thanks.

It looks like that ethernet shield uses pins 4, 9, 10, 11, 12, and 13 and optionally 2. I assume you mean Pins 2 and 3 when you say "by using the interrupt pins" so make sure the solder jumper at Pin 2 of the ethernet shield isn't jumpered.

The "EtherCard" library is notoriously large. The ENC28J60 is a dumb ethernet adapter so the entire TCP/IP stack has to be in the library. This often causes memory exhaustion problems. You might want to invest in a modern Ethernet Shield using the Wiznet W5100 chip. Yes, it costs P 980.00 instead of P 785.00 but the TCP/IP stack is in the chip so the library can be much smaller.

http://playground.arduino.cc//Main/PinChangeIntExample

I tried using the example at the link above and used a different pin as interrupt. At the first few readings it is correct at later readings it becomes wrong again.
I'm still using the ENC28J60 while I cannot purchase the W5100.
I just need to show it works properly for now.

I tried sending the data from the card reader thru another arduino board using the tx(pin 1) and rx(pin 0) even used software serial to send it thru other digital pins but the data is still messed up and again when I turn off the ethernet shield is off everything works fine.
Do I really have no option but to change the ethernet shield that I am using?

Is there any difference if I use an https://www.arduino.cc/en/Main/ArduinoEthernetShield?
Found a store where I can buy it.