Trouble with TowerPro SG90 servos.

Hello!! Recently, I bought a pack of 5 TowerPro SG90 micro servos. I tried running them with the basic sweep example code given in the IDE. But despite making some noise and getting heated, the servo just doesn't rotate. I powered it using a standard phone charger which provides 5.03 Volts (double checked with a mutimeter). I am using the PWM pins too. I'm pretty sure I have wired it up properly. Also, I even opened up one of the servos. The gears weren't stuck or anything. Please help. Thanks in advance.

If you post a circuit diagram showing exactly what you wired where then we could be pretty sure you wired it up properly too.

Meanwhile phone chargers are not power supplies and some will not supply any power unless they are connected to batteries, not servos. Also do you have the ground on the “charger” and the Arduino connected together? Have you tried all the servos…you can get the odd bad one but five bad ones would be very unusual.

Steve

@slipstick Thanks a lot. I did not make the ground common. I'm a noob. Can you tell me why we should provide a common ground?

Ground is what all voltages and signals are referenced to. If all grounds are not common then the different devices can see different things e.g. the servo may not even notice the Arduino signal that's trying to drive it because it's effectively just floating in mid-air.

Steve

Oh. I get it now. Thanks a lot.

You don't need to use PWM pins for servos.

Show what you wired up, otherwise there's no way we can see what you did wrong.

it’s working fine now. I did not know that we had to give a common ground.