Troubles with DHT11 and Attiny85

I have recently gotten into Arduino programming and I have been using Attiny85 microprocessor. My issue currently is that I have attempted to connect 433mhz RF transmitters to the Attiny processors, I had initial success and I was able to transfer float values and integers using data structures. The library I was using for the task was the RadioHead ASK library. I then wanted to attempt to connect a DHT11 sensor to the Attiny85 and transfer the data to an Arduino Uno. The problem is that the Attiny cannot seem to read data from the DHT11, I have tried many libraries including the DHT11Lib, DHT11Stable and the Adafruit DHT libraries. I have taken a multimeter to my circuit and I know that the DHT and the Attiny are communicating due to voltage fluctuations. When I try to run the code I only get values of 0 on the receive side, I know the transmit and receive functions work because I can hook up other sensors that aren’t the DHT. I have tried looking everywhere for someone with a similar issue but the solutions I find dont seem to work for my scenario. I had gotten part of the code from a previous forum thread on how to send multiple float values. I am using a 5.2k resistor with my DHT11. I had gotten this code to work with Arduino to Arduino transmission but I am stuck on getting the Attiny to want to work with the DHT11.

Example of Code:

#include <dht.h>
#include <RH_ASK.h>

#define DHT11_PIN 4
dht DHT;


//RH_ASK driver;
RH_ASK driver(2000, 11, 3);


struct dataStruct {
  float temp;
} myData;

byte tx_buf[sizeof(myData.temp)] = {0};



void setup()
{
  driver.init();
  //Serial.begin(9600);
}

void loop()
{
  int chk = DHT.read11(DHT11_PIN);

  myData.temp = DHT.temperature;

  //Serial.println(myData.temp);

  memcpy(tx_buf, &myData.temp, sizeof(myData.temp) );
  byte zize = sizeof(myData.temp);

  driver.send((uint8_t *)tx_buf, zize);

  //  driver.send((uint8_t *)msg, strlen(msg)); 
  driver.waitPacketSent();

  
  
  delay(1000);
}

Do the DHT and RadioHead libraries use the same hardware timer?

I believe so. Wouldn't an issue like that interfere with data transmission from Arduino to Arduino. The issue is only present when using an Attiny chip, is there an issue with some sort of serial communication that I need to have?

NwhitmoreSTC:
I believe so.

Well, they're not allowed to.

Have you tried to get the dht11 working with just the attiny and no radio just to prove it works?

Always test components of a large program one at a time.

Always test components of a large program one at a time.

There aren't enough +1s

Was able to get the issue fixed on my own. The Attiny core I was using wasn't allowing the DHT11 to be read, I switched cores and it worked just fine, thanks for the help though