Troubleshooting Arduino Mega 2560 stk500v2_getsync() timeout

I began receiving the avrdude: stk500v2_getsync(): timeout communicating with programmer error a few days ago. It happened all of a sudden and I'm not sure what's causing it, looking for some help.

I'm using Windows 8, Arduino IDE 1.6.5, an example sketch, and no additional pins are connected. Prior to this occuring I was able to successfully upload sketches while working on a project. I switched to an Arduino Uno for some other work, then came back to the mega. I didn't change anything major in my system, and did change back to the correct port and board in the IDE.

Steps I've tried: Verifying the port matches between windows COM port and the IDE. Verifying board is correctly chosen in the IDE. Changing USB cables. My PIN 13 LED is blinking, as well as the Green LED constantly lit up. I was able to burn a bootloader into the Mega using my Uno as the ISP by following Nick Gammon's guide and code, but continue to be unable to upload via USB Changing or updating my Arduino drivers. Changing to 1.0.6. classic

The same problem has persisted throughout these attempts.

Things I've noticed: The loop-back test fails. When I plug in my Uno into the USB drive it shows in windows as COM Port 4, and the Mega shows as COM Port 3.

Any additional troubleshooting steps would be great, anything on the website under general troubleshooting or other forum threads with this issue I've likely tried already

Failing the loop-back test points to a problem with your usb-serial chip. What chip does your Mega use?