Troubling Uploading sketch

Hello, I am trying to upload my sketch to my customer board and I am getting this error:
avrdude: stk500_getsync(): not in sync: resp=0x00

I have found this error has to do with the wrong board being selected in the Arduino sketch loader. Here is the tricky part, my board is not an Arduino rather a custom board with an ATMega328-TQFP (ATMega328 - TQFP - COM-09261 - SparkFun Electronics). I currently have selected the duemilanove or nano w/ATMega328.

Since my board is custom and not an Arduino, should I use a different tool to load my sketches?

Thanks

Does it have a bootloader on it?

Hi Nick,

Why you are quite right, it appears I do not have a bootloader. While your link is very informative, it doesn't meet my situation, and here is why.

I did not breadboard my design (slapping my own hand for that one) and started with the design, PCB and soldering work. so I cannot add the bootloader the way you have show, unless I start configuring jumpers from my Uno to the board, and that I am not thrilled to do.

My board can be powered via battery or USB, can I run my board and UNO on battery, then bridge them via USB to USB and load that way?

Thanks.

What, are you saying that you can’t get to the SPI pins?

Not easily. Looking at your work, you are so much more in the know than I am, but the ATMega328 TQFP has such small legs and they are soldered to the board it is not easy. With my station I could probably run some jumpers.

Any tips or tricks with the jumpers? Thanks.

I'm trying to understand this board of yours. Did you solder on some legs but not others? Normally you would bring out the SPI pins (SCK, MOSI, MISO) plus /RESET (and GND and VCC) in order to program it. Because if you don't, and haven't got a bootloader on it, then you won't be able to use it. Can you show a photo (or link to) the board?

Hi Nick,

I am attaching my schematic. I am starting to worry, and you will see why. I didn’t connect the MOSI,MISO,SCK because in my design phase I thought I needed to connect those to a programming header…which now in retrospect would have been a good idea.

Did I already mention I am slapping my hand for not bread boarding this?

Temp Humidity Schematic v3.brd (30.2 KB)

That was the board file, how about the schematic?

Sorry Nick, day that won’t end.

Temp Humidity Schematic v3.sch (90.3 KB)

Hi Nick,

Have you had a chance to look at that schematic? Do I need to jump those pins in order to boot load? Will my board need those permanently hooked up to run?

Thanks Nick.

If there is no boot loader on the chip, you will have to use a ISP programmer.

Since you're using a TQFP package... if you are very very careful, you could solder a wire to the legs (I have done this my self). If money isn't a issue a TQFP probe would be the other way, but be warned these things are usually expensive.

$700+ for a TQFP....chump change...pffftttt sorry I tried to type that with a straight face. :stuck_out_tongue_closed_eyes: Thanks for that idea, but unfortunately, money is a restriction for me.

I probably will have to jump with, sad truth is I am not a neurosurgeon not because of smarts, but because of shaky hands :slight_smile:

Definitely creating future designs with ISP programmer heads.

Hi Nick,

Running the chip detector results in me needing to go to the "Chip Not Detected" section. I have a resonator connected to pins 9 & 10, not an oscillator. From my understanding, a resonator is a component of an oscillator, is that correct?

Since I have something connected to those pins is "hotwiring" an ocillator an option?

Thanks Nick,
Charles

FYI, more people could help you if you posted a readable version of your schematic (pdf) and also legible pictures of your setup/board.