trying to compile marlin to my ender 3, getting an erro

so followed all the steps on E3Ds site and i get this error

Arduino: 1.8.13 (Windows 10), Board: "Sanguino, ATmega1284 or ATmega1284P (16 MHz)"

Sketch uses 125530 bytes (96%) of program storage space. Maximum is 130048 bytes.

Global variables use 6297 bytes (38%) of dynamic memory, leaving 10087 bytes for local variables. Maximum is 16384 bytes.

avrdude: Expected signature for ATmega1284P is 1E 97 05

         Double check chip, or use -F to override this check.

Wrong microcontroller found.  Did you select the right board from the Tools > Board menu?



This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

any ideas?

What chip does YOUR ender 3 have?

Please do this:

  • (In the Arduino IDE) File > Preferences
  • Uncheck the checkbox next to "Show verbose output during: compilation"
  • Check the checkbox next to "Show verbose output during: upload
  • Click "OK"
  • Try an upload
  • After the upload fails, copy and paste the output in a reply here, just as you did before (thanks!)

missdrew:
What chip does YOUR ender 3 have?

atmega1284p

pert:
Please do this:

  • (In the Arduino IDE) File > Preferences
  • Uncheck the checkbox next to "Show verbose output during: compilation"
  • Check the checkbox next to "Show verbose output during: upload
  • Click "OK"
  • Try an upload
  • After the upload fails, copy and paste the output in a reply here, just as you did before (thanks!)
Arduino: 1.8.13 (Windows 10), Board: "Sanguino, ATmega1284 or ATmega1284P (16 MHz)"

Sketch uses 125530 bytes (96%) of program storage space. Maximum is 130048 bytes.

Global variables use 6297 bytes (38%) of dynamic memory, leaving 10087 bytes for local variables. Maximum is 16384 bytes.

C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega1284p -carduino -PCOM3 -b115200 -D -Uflash:w:C:\Users\irish\AppData\Local\Temp\arduino_build_258346/Marlin.ino.hex:i 



avrdude: Version 6.3-20190619

         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         Copyright (c) 2007-2014 Joerg Wunsch



         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"



         Using Port                    : COM3

         Using Programmer              : arduino

         Overriding Baud Rate          : 115200

         AVR Part                      : ATmega1284P

         Chip Erase delay              : 55000 us

         PAGEL                         : PD7

         BS2                           : PA0

         RESET disposition             : dedicated

         RETRY pulse                   : SCK

         serial program mode           : yes

         parallel program mode         : yes

         Timeout                       : 200

         StabDelay                     : 100

         CmdexeDelay                   : 25

         SyncLoops                     : 32

         ByteDelay                     : 0

         PollIndex                     : 3

         PollValue                     : 0x53

         Memory Detail                 :



                                  Block Poll               Page                       Polled

           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack

           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------

           eeprom        65    10   128    0 no       4096    8      0  9000  9000 0xff 0xff

           flash         65    10   256    0 yes    131072  256    512  4500  4500 0xff 0xff

           lock           0     0     0    0 no          1    0      0  9000  9000 0x00 0x00

           lfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00

           hfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00

           efuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00

           signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

           calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00



         Programmer Type : Arduino

         Description     : Arduino

         Hardware Version: 3

         Firmware Version: 4.4

         Vtarget         : 0.3 V

         Varef           : 0.3 V

         Oscillator      : 28.800 kHz

         SCK period      : 3.3 us



avrdude: AVR device initialized and ready to accept instructions



An error occurred while uploading the sketch

Reading | ################################################## | 100% 0.00s



avrdude: Device signature = 0x1e950f (probably m328p)

avrdude: Expected signature for ATmega1284P is 1E 97 05

         Double check chip, or use -F to override this check.



avrdude done.  Thank you.





This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

sharpy345:

avrdude: Device signature = 0x1e950f (probably m328p)

avrdude: Expected signature for ATmega1284P is 1E 97 05

OK, that is very useful information for us.

sharpy345:
so followed all the steps on E3Ds site

Please post a link to the instructions you're following so we can understand what you're doing. Many of the people here on the forum (including myself) are very knowledgeable about Arduino, but not at all about 3D printers.

pert:
OK, that is very useful information for us.

Please post a link to the instructions you're following so we can understand what you're doing. Many of the people here on the forum (including myself) are very knowledgeable about Arduino, but not at all about 3D printers.

this, although the links they had didnt work anymore so i had to go find new ones for the Sanguino and for the marlin files

OK, I think you skipped this part of Step 11:

From now on you should be able to connect the Ender 3 to the computer via the mini USB cable.

Once you finish burning the bootloader on the Ender 3 using the Uno, you need to disconnect the Uno from the Ender 3 and then connect the Ender 3 directly to your computer with the USB cable.

The reason you're getting this error is because you're trying to upload Marlin to the Uno you were using as an "Arduino as ISP" programmer to burn the bootloader instead of uploading it to the 3D printer control board.

pert:
OK, I think you skipped this part of Step 11:Once you finish burning the bootloader on the Ender 3 using the Uno, you need to disconnect the Uno from the Ender 3 and then connect the Ender 3 directly to your computer with the USB cable.

The reason you're getting this error is because you're trying to upload Marlin to the Uno you were using as an "Arduino as ISP" programmer to burn the bootloader instead of uploading it to the 3D printer control board.

Arduino: 1.8.13 (Windows 10), Board: "Sanguino, ATmega1284 or ATmega1284P (16 MHz)"

Sketch uses 125530 bytes (96%) of program storage space. Maximum is 130048 bytes.

Global variables use 6297 bytes (38%) of dynamic memory, leaving 10087 bytes for local variables. Maximum is 16384 bytes.

C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega1284p -carduino -PCOM4 -b115200 -D -Uflash:w:C:\Users\irish\AppData\Local\Temp\arduino_build_258346/Marlin.ino.hex:i 



avrdude: Version 6.3-20190619

         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         Copyright (c) 2007-2014 Joerg Wunsch



         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"



         Using Port                    : COM4

         Using Programmer              : arduino

         Overriding Baud Rate          : 115200

avrdude: ser_open(): can't set com-state for "\\.\COM4"



avrdude done.  Thank you.



An error occurred while uploading the sketch



This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

thats what i get now

The reason for this error is you still have the port from the Uno selected. The 3D printer control board has a different COM port. You need to select that port from the Arduino IDE's Tools > Port menu before uploading.

If you don’t know which port is your 3d printer board, you can find it like this:

  • Unplug your 3D printer's USB cable from the computer.
  • Tools > Port
  • Note the ports, if any, listed in the menu.
  • Close the Tools menu. The ports list is only updated when the Tools menu is re-opened, so this step is essential.
  • Plug your 3D printer's USB cable back into the computer.
  • Tools > Port - The new port listed in the menu is your 3D printer board.

pert:
The reason for this error is you still have the port from the Uno selected. The 3D printer control board has a different COM port. You need to select that port from the Arduino IDE's Tools > Port menu before uploading.

If you don’t know which port is your 3d printer board, you can find it like this:

  • Unplug your 3D printer's USB cable from the computer.
  • Tools > Port
  • Note the ports, if any, listed in the menu.
  • Close the Tools menu. The ports list is only updated when the Tools menu is re-opened, so this step is essential.
  • Plug your 3D printer's USB cable back into the computer.
  • Tools > Port - The new port listed in the menu is your 3D printer board.

so i unplugged it, no ports listed, closed the tools menu, plugged it back in, said com4, hit upload and

Arduino: 1.8.13 (Windows 10), Board: "Sanguino, ATmega1284 or ATmega1284P (16 MHz)"

Sketch uses 125530 bytes (96%) of program storage space. Maximum is 130048 bytes.

Global variables use 6297 bytes (38%) of dynamic memory, leaving 10087 bytes for local variables. Maximum is 16384 bytes.

C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega1284p -carduino -PCOM4 -b115200 -D -Uflash:w:C:\Users\irish\AppData\Local\Temp\arduino_build_258346/Marlin.ino.hex:i 



avrdude: Version 6.3-20190619

         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         Copyright (c) 2007-2014 Joerg Wunsch



         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"



         Using Port                    : COM4

         Using Programmer              : arduino

         Overriding Baud Rate          : 115200

avrdude: ser_open(): can't set com-state for "\\.\COM4"



avrdude done.  Thank you.



An error occurred while uploading the sketch



This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Hmmm. Try restarting your computer. Sometimes the port can get stuck in a state where it can't be used and the restart recovers it.

pert:
Hmmm. Try restarting your computer. Sometimes the port can get stuck in a state where it can't be used and the restart recovers it.

Arduino: 1.8.13 (Windows 10), Board: "Sanguino, ATmega1284 or ATmega1284P (16 MHz)"

Sketch uses 125530 bytes (96%) of program storage space. Maximum is 130048 bytes.

Global variables use 6297 bytes (38%) of dynamic memory, leaving 10087 bytes for local variables. Maximum is 16384 bytes.

C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega1284p -carduino -PCOM4 -b115200 -D -Uflash:w:C:\Users\irish\AppData\Local\Temp\arduino_build_773282/Marlin.ino.hex:i 



An error occurred while uploading the sketch

avrdude: Version 6.3-20190619

         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         Copyright (c) 2007-2014 Joerg Wunsch



         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"



         Using Port                    : COM4

         Using Programmer              : arduino

         Overriding Baud Rate          : 115200

avrdude: ser_open(): can't set com-state for "\\.\COM4"



avrdude done.  Thank you.





This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

still nothing
also doesnt work when i try a new port

OK, unfortunately I don't know how to solve that error. I can suggest a workaround though:

  • Disconnect the USB cable of the 3D printer from your computer.
  • Connect your Uno back up to the 3D printer, following the instructions at Step 7 of Hemera Ender 3 Firmware – E3D Online
  • Connect the Uno to your computer with a USB cable.
  • (In the Arduino IDE) Tools > Port > select the port of the Uno.
  • (In the Arduino IDE) Sketch > Upload Using Programmer
  • Wait for the upload to finish successfully.
  • Unplug the Uno's USB cable from your computer.
  • Disconnect the Uno from the 3D printer.

After that, your 3D printer firmware will be updated and you can use it as usual.

The only downside to this workaround is you will always need to reconnect the Uno to your 3D printer every time you want to update the 3D printer firmware. But that's not so bad. If you do it a lot, you can buy a 6 pin USBasp programmer from eBay to use instead of the Uno. The USBasp programmer has a cable that plugs right in to your 3D printer board so you don't need to deal with getting all the jumper wires between the Uno and the printer board just right every time. But the Uno used as an "Arduino as ISP" programmer works great and as a bonus you have a nice Uno to play around with when you're not using it as a programmer.

pert:
OK, unfortunately I don't know how to solve that error. I can suggest a workaround though:

  • Disconnect the USB cable of the 3D printer from your computer.
  • Connect your Uno back up to the 3D printer, following the instructions at Step 7 of Hemera Ender 3 Firmware – E3D Online
  • Connect the Uno to your computer with a USB cable.
  • (In the Arduino IDE) Tools > Port > select the port of the Uno.
  • (In the Arduino IDE) Sketch > Upload Using Programmer
  • Wait for the upload to finish successfully.
  • Unplug the Uno's USB cable from your computer.
  • Disconnect the Uno from the 3D printer.

After that, your 3D printer firmware will be updated and you can use it as usual.

The only downside to this workaround is you will always need to reconnect the Uno to your 3D printer every time you want to update the 3D printer firmware. But that's not so bad. If you do it a lot, you can buy a 6 pin USBasp programmer from eBay to use instead of the Uno. The USBasp programmer has a cable that plugs right in to your 3D printer board so you don't need to deal with getting all the jumper wires between the Uno and the printer board just right every time. But the Uno used as an "Arduino as ISP" programmer works great and as a bonus you have a nice Uno to play around with when you're not using it as a programmer.

Arduino: 1.8.13 (Windows 10), Board: "Sanguino, ATmega1284 or ATmega1284P (16 MHz)"

Sketch uses 125530 bytes (96%) of program storage space. Maximum is 130048 bytes.

Global variables use 6297 bytes (38%) of dynamic memory, leaving 10087 bytes for local variables. Maximum is 16384 bytes.

C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega1284p -cstk500v2 -Pusb -Uflash:w:C:\Users\irish\AppData\Local\Temp\arduino_build_732719/Marlin.ino.hex:i 



avrdude: Version 6.3-20190619

         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         Copyright (c) 2007-2014 Joerg Wunsch



         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"



         Using Port                    : usb

         Using Programmer              : stk500v2

avrdude: usbdev_open(): did not find any USB device "usb" (0x03eb:0x2104)



avrdude done.  Thank you.



An error occurred while uploading the sketch



This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

starting to think this uno hates me lol

This error is caused by having the wrong programmer selected from the Arduino IDE's Tools > Programmer menu. I omitted that from my previous instructions because I assumed you already had it configured from when you burned the bootloader the last time you followed the Hemera Ender 3 Firmware – E3D Online tutorial.

Please select Tools > Programmer > Arduino as ISP in the Arduino IDE and then follow the instructions in my previous reply again.

lol think i got it now.. im an idiot and had selected arduinoisp instead of arduino as isp lol, thanks for the help pert

You're welcome. I'm glad to hear it's working now.

That "ArduinoISP" vs "Arduino as ISP" thing is super confusing, especially considering the sketch used to turn your Uno into an "Arduino as ISP" is named "ArduinoISP".

Enjoy your updated 3D printer!
Per

pert:
You’re welcome. I’m glad to hear it’s working now.

That “ArduinoISP” vs “Arduino as ISP” thing is super confusing, especially considering the sketch used to turn your Uno into an “Arduino as ISP” is named “ArduinoISP”.

Enjoy your updated 3D printer!
Per

thanks, this is only temporary until my new board that is better gets here lol then i get to enjoy getting that to work, have a great day.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.