Trying to identify problem with I2C connection between Mega and Nano

[SOLVED: I didn’t have slave code uploaded to the Nano. Still learning. Thanks for the help!]

Beginner here, please forgive me if I’m missing something very simple.

I’m trying to connect a Mega to a Nano using I2C, but the I2C scanner sketch I’m using (below) says “No I2C devices found.” So I’m trying to identify where the problem is.

I successfully connected an Uno to the Mega via I2C, so I think the wiring is not at fault. Just in case, though, I’ll describe it and post pics.

I have the Mega’s 20 pin connected to the Uno’s 4 pin and the 21 connected to Uno’s 5, each with a 4k7ohm pull-up resistor. The GND and 5V pins are also connected. (pics of wiring below) The I2C scanner sees the Uno. Success!

But when I unplug the wires from the Uno and plug them into the Nano in the same pins, there’s no I2C connection.

As far as I can tell, the Nano works fine – I ran a blink sketch on it, and that worked. Is there some other way I can test to see if/where the problem lies in the Nano?

Am I missing something? Thanks in advance for reading this and apologies if my mistake is very dumb.

Here’s the scanner code, if that helps:

// --------------------------------------
// i2c_scanner
// Version 1
//    This program (or code that looks like it)
//    can be found in many places.
//    For example on the forum.
//    The original author is not know.
// Version 2, Juni 2012, Using Arduino 1.0.1
//     Adapted to be as simple as possible by user Krodal
// Version 3, Feb 26  2013
//    V3 by louarnold
// Version 4, March 3, 2013, Using Arduino 1.0.3
//    by user Krodal.
//    Changes by louarnold removed.
//    Scanning addresses changed from 0...127 to 1...119,
//    according to the i2c scanner by Nick Gammon
// Version 5, March 28, 2013
//    As version 4, but address scans now to 127.
//    A sensor seems to use address 120.
// Version 6, November 27, 2015.
//    Added waiting for the Leonardo serial communication.
// This sketch tests the standard 7-bit addresses
// Devices with higher bit address might not be seen properly.

#include <Wire.h>

void setup()

  Serial.println("\nI2C Scanner");

void loop()
  byte error, address;
  int nDevices;


  nDevices = 0;
  for(address = 1; address < 127; address++ ) 
    // The i2c_scanner uses the return value of
    // the Write.endTransmisstion to see if
    // a device did acknowledge to the address.
    error = Wire.endTransmission();

    if (error == 0)
      Serial.print("I2C device found at address 0x");
      if (address<16) 
      Serial.println("  !");

    else if (error==4) 
      Serial.print("Unknown error at address 0x");
      if (address<16) 
  if (nDevices == 0)
    Serial.println("No I2C devices found\n");

  delay(5000);           // wait 5 seconds for next scan

Where is the nano in the pictures?
Seems you have a shield connected - which one?

Attaching a pic of the Nano connected but not showing up on the i2c scanner.

The shield is an Adafruit Music Maker.


Ah! Yes! Thank you! I’m dumb!

I guess I didn’t realize that I needed to upload slave code to the Nano in order to be seen by the Mega’s scanner. I uploaded this to the nano:

#include <Wire.h>

void setup() {

void loop() {

And now everything works. Thanks again!