Trying to replicate 433Mhz Signal And Having Issues

Hi folks - I have a Heat n Glo fireplace with model RC300 remote. I've followed several tutorials and articles online, and I've been trying two approaches to build an arduino transmitter to replicate the remote's signals.

  1. Use the library posted here to send the signals.

  2. Use the rc-switch library based approach detailed with this project

Some background:

  • I have successfully done a hello world style project where I transmit a string from my 433mhz transmitter (gowoops, bought from amazon) to a receiver. One is hooked to an uno, one to a mega
  • I have successfully used an SDR with SDR# and Audacity to examine the waveforms I'm sending, as well as what I'm sniffing from the remote

This post here has screenshots of my sniffed wave form and details two issues I'm facing with the rc-switch approach. Namely, there are delays in the sniffed wave form, and when I send a long string of 1s and 0s, they don't seem to be replicated in my transmission.

When I try to use the FireplaceRF library (which I do believe has the right signal protocol for my fireplace), my transmitted wave form looks ...odd. The sniffed wave form essentially has 1s that look like zeros and ones (LOW is essentially zero, and HIGH is a bit above that). But what I transmit looks like repeated sin waves with gaps in them.

I'm at a loss for how to move forward. Would be happy to share any information necessary but could really use some help to troubleshoot.

I feel like I'm close - I have a sniffed wave form, I have a library that in theory should output that wave form, or I can just use RC-Switch or another library to output what I need that matches the sniff. Not sure where I'm going wrong. Hardware, software, or both.

The posted waveforms do not look like RC-Switch format to me. There are too many bits in the message and the sync/start pulse does not appear to be long enough. But if you can open the remote and figure out what chip is being used, that may settle the issue.

Take a look at these examples of RC-Switch waveforms: Wireless Remote Control PT2272 for Arduino | Detect And Zero Rightmost One

For general RF remote signal decoding, the approach taken in this blog article works very well: Reverse Engineer Wireless Temperature / Humidity / Rain Sensors — Part 1 « RAYSHOBBY.NET

Thanks so much! I will read that. In the meantime, I ended up getting fed up and just sent the raw timings myself, and I was able to get that to work!

I will make a different post, but FWIW it is working great on the mega with my transmitter.

When I tried to switch to a NodeMCU ESP8266 12, I used the same wiring and same transmitter, but I just got a very minimal signal (as observed with the USB SDR). It was sending something very weak, because when I unplugged power or the data pin I lost it…

For the Node MCU wiring, I wired the power for the transmitter to VIN, data to a data pin, and ground to one of the grounds. I tried switching from VIN to 3.3V but that just reduced the already weak signal (though it was still there).

…I did then try to take a multi meter (without really knowing what I’m doing), and I touched the meter to the gnd pin and vin pin on the board. It smoked a little :(. Then my weak signal went to super weak. Did I fry the board? Any ideas what I should’ve done in the first place?

Sounds like the multimeter was on current measurement setting, which is basically a short circuit. Smoke usually means you destroyed something.

Always use the multimeter voltage ranges for testing, unless you specifically want to measure current flow (which can be dangerous to both the meter and the circuitry).

Thanks, yeah I was measuring with voltage range but I had the red lead connected to microM instead of "INPUT". Live and learn.

Anyway - would still really appreciate any guidance for why the nodeMCU signal was low/not working in the first place? Or how to best troubleshoot?