Trying to understand MOSFET behavior

Hi folks - see attached schematic snippet. (the drain coming into the top of the MOSFET is from the same 9V power source as the NodeMCU, the source coming out the bottom of the MOSFET goes to ground, as does the GND pin on the NodemCU).

MOSFET Datasheet: https://www.infineon.com/dgdl/irli520npbf.pdf?fileId=5546d462533600a401535663ef6625bd

I have everything on a breadboard but I'm seeing behavior I can't explain:

When D3 is "off" and I use a multimeter to measure the voltage between each pin and ground, I'm seeing:

  • Gate: 0.180V
  • Drain: 8.2V
  • Source: .014V

When D3 is "on" and I use a multimeter to make the same tests, I get:

  • Gate: 2.8V
  • Drain: 6.8V
  • Source: 0.85V

I can't figure out why the source voltage in the "on" case is only 0.85V. I tried multiple mosfets and they all show the same. Looking at the datasheet, it says "Gate threshold voltage is 1-2V"....could passing in 2.8V be causing the above behavior? (I thought I had tried other simpler circuits a few months ago with the NodeMCU connected to a MOSFET gate and didn't have this problem; didn't take measurements though - it "just worked")

(I'm also surprised that the MOSFET being gate ON causes the drain voltage to drop 1.4V....but maybe that's a characteristic of the MOSFET somewhere listed on the datasheet that I don't understand from reading?)

Really appreciate the help - this board is a life savor and truly helping me learn; I'm still a beginner.

You should put all you fireworks e-fuse questions in the same thread.
Cross- posting wastes time.

The mosfet link points to a logic level IRLI520,. Your diagram uses a non-logic IRF540.
So what are you using. The IRF540 won't work with 3.3volt logic (hinted in your other thread).

2.8volt on the gate when the pin is HIGH is wrong. Should be almost 3.3volt.
You didn't post any code yet. Did you set the pin to OUTPUT, or is it a PWM/pulse that your slow DMM can't follow.
What colour/type is the LED. Some LEDs could draw 4.5mA with a 330 ohm resistor.
That puts a heavy load on an ESP pin that shouldn't deliver more than 7mA.
Use a white/blue LED, or increase CL resistor to 1k.

Voltage on the source is always Vgt (threshold voltage) lower than the gate.
If you want 9volt on the 6ohm resistor, then the gate must be at least 12volt.
The ESP can't provide that, so a source follower won't work here.
The resistor/e-fuse must be in the drain line, or you need to switch high-side with a p-channel fet.

Drain voltage drops a bit, because the 9volt smoke alarm battery can't keep up with the 140mA that the e-fuse in your circuit now draws (0.85volt / 6ohm).
A 6ohm load with a 9volt supply should draw 1.5Amp. The supply must be able to provide at least that.
Leo..

Super helpful, thank you. Lots of things to go look at. Will revert back.

(sorry about the cross post I thought I was being helpful by subsegmenting by topic)

Other answers to your questions:

  • I'm using an IRLI520, I just forgot to update the schematic :frowning:

  • I set the pin to OUTPUT (Will post code but forgot to push to my repo so need to get from my laptop tomorrow)

  • LED: It's red - https://www.lumex.com/spec/SSL-LX3054SRD.pdf
    -> Got it will try increasing LED CL resistor to get the V back up to 3.3

  • The fuse is upstream from the drain; so it should be fine if the voltage is lower by this point - the 6 ohm resistor was there to be current limiting to prevent a current spike from starving the controller. But based on what you're saying I get it that the resister should be in the drain line along with the firework. That makes sense.

  • For a power supply I've been using a bench top power supply, so shouldn't have an issue supplying but maybe the combination of other problems is causing drain to drop a bit....?

Small update - got 10m to play around this morning -- removing the pulldown resistor on the MOSFET gate made the IO/gate voltage go back to 3.3-3.7V (generally hanging out at 3.5V but a little variable). Not sure why that resistor directly connected from gate to ground would cause such a voltage drop from the IO Pin....

With the gate on, I also measured the voltage before and after the efuse - and it is the efuse that causes the drop in voltage on the drain from 8.2V to 6.8V (I presume because it's adding resistance.

It still didn't fire then, so I removed the 6 ohm resistor, and that caused the current being pulled from the power supply to pop up to 500mV, which didn't fire the e-fuse. Until I then used the multimeter to measure voltage drop on the fuse - with the multimeter connected to ground, as soon as I touched the positive probe to the eFuse negative connection, it fired. Super odd - not sure on potential reasoning for that............will have to spend a lot more time playing with things I guess.