Trying to upload Repetier code, "twi.c no such file" error [SOLVED]

Hello forum,

I haven’t used Arduino in a while but was excited when I saw that my SeeMeCNC Rostock Max V2 3D printer required its use for uploading the board; it’s great to see that Arduino being used on something new! However, I followed the instructions for the firmware upload to a “t” and have run into an unfortunate error.

When I go to upload the Repetier software to my RAMBo controller, which is a glorified Mega 2560, I get the following error:

Arduino: 1.6.7 Hourly Build 2015/11/17 06:13 (Mac OS X), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

Warning: platform.txt from core 'Arduino AVR Boards' contains deprecated recipe.preproc.macros="{compiler.path}{compiler.cpp.cmd}" {compiler.cpp.flags} {preproc.macros.flags} -mmcu={build.mcu} -DF_CPU={build.f_cpu} -DARDUINO={runtime.ide.version} -DARDUINO_{build.board} -DARDUINO_ARCH_{build.arch} {compiler.cpp.extra_flags} {build.extra_flags} {includes} "{source_file}", automatically converted to recipe.preproc.macros="{compiler.path}{compiler.cpp.cmd}" {compiler.cpp.flags} {preproc.macros.flags} -mmcu={build.mcu} -DF_CPU={build.f_cpu} -DARDUINO={runtime.ide.version} -DARDUINO_{build.board} -DARDUINO_ARCH_{build.arch} {compiler.cpp.extra_flags} {build.extra_flags} {includes} "{source_file}" -o "{preprocessed_file_path}". Consider upgrading this core.
sketch/libraries/twi.c:1:17: fatal error: twi.c: No such file or directory
 #include <twi.c>
                 ^
compilation terminated.
exit status 1
Error compiling.

  This report would have more information with
  "Show verbose output during compilation"
  enabled in File > Preferences.

How do I fix this? My first idea is that I started using the 1.6.6 build and the instructions call for 1.6.1 (although they say this shouldn’t be a problem). Even in downloading the older version, from which this error code is from, it says “Arduino 1.6.7”. Is it not possible to use 1.6.1?

My second idea is that maybe I need to update or refresh the libraries. I am on Mac OS X and saw some instructions for removing the libraries file Windows but it didn’t specify anything for Mac. I also used the board manager and tried versions 1.6.2, 1.6.8, and 1.6.9 (didn’t work at all) and nothing changed anything.

Does anyone have any other ideas? Thanks for any help!

Looks like you accidentally downloaded the hourly development build. Before you install 1.6.6 (or any other version) you should rename or delete the Arduino15 directory:

On Mac OS X:
/Users/(username)/Library/Arduino15

On Windows:
C:\Users(username)\AppData\Roaming\Arduino15

On Linux:
/home/(username)/.arduino15 (a.k.a. ~/.arduino15)

Since I am on Mac, I went to /Users/[myusername])/Library/Arduino15 and renamed it to /Users/[myusername]/Library/Arduino15_old, then I installed Arduino 1.6.6. I still got the same error. However, there is also a /Users/[myusername]/Library/Arduino folder with a preferences.txt file and I changed the name of that directory, then it worked. Thanks for the hint johnwasser. Marking this as solved.