Trying to use Sparkfun Xbee shield and Digi modules to control robot

Hi. I'm trying to build an Xbee-based robot, but I have absolutely no idea what should be in my sketch
or the pins I should connect. I am trying to continuously send from my Arduino and first Xbee a digital value and an analog value to the second Xbee, and to continuously send back two analog values back from
the robot (from a microphone and a low-lux camera). I will be using X-CTU software from Digi to configure the Xbee
modules. Any help will be very much apprectiated. Thanks!

Xbees are basically RS232 wire-replacements. IOW, you take a regular RS232 connection between 2 devices, break the wires, and put the XBees in the path. Then, for most purposes, you don't even know the XBee is in there.

  1. so what you should do first is ... write your program to communicate with the robot via a regular RS232 connection.

  2. once that is working, then ... figure out how to connect the XBee modules in place of the wires.

One small step at a time. It also helps to know which Ardunio board you are using, as the Xbee hookup scheme depends on that.

It also helps to know which Ardunio board you are using, as the Xbee hookup scheme depends on that.

It helps to know which shield you are using, too. Not to mention the benefit of knowing which XBees you have.

Ditto to what Paul said.

Yes, but I don't have an Arduino on the robot end. Is there a way that I could turn the robot Xbee's pins on/off and write analog values from the Arduino Uno-based controller without having an additional Arduino on the robot?

Xbee modules have a few I/O pins, which I’ve never tried using myself, but to do anything other than simple R/C control, you need a cpu board on the robot. There are boards around with Arduino chips on them which are much smaller than UNO size. Start at the bottom of this page,
http://arduino.cc/en/Main/Products

Thanks!