Turn Off IDE 2.0.0-Beta5 Editing Popup?

When the cursor moves over a function or method when trying to make an edit, the informational popup that appears frequently makes it difficult to make the desired editing change since the popup covers the code being edited. Is there a way I can turn this completely off – will save me time and frustration.
Thanks,
Al

Press “Escape to remove it” - discovered that by accident.

That’s helpful. Wish ESC did more than just temporarily turning off the ‘current’ popup, but certainly still useful. I think it would be better if ESC just temporarily tuned on the current popup! :wink:
Thanks!
Al

Hi @ark1320. There is a known bug regarding the placement of the definition hover covering the code:

Once this issue is fixed, the hover will be less likely to interfere with the editing of the sketch. Hopefully that will be resolved in an upcoming release of the IDE.

For now, the placement of the hover can be quite annoying. I also find things popping up while I’m working to be distracting to the point that the undeniable value they provide does not outweigh the harm they do to my productivity. For these reasons, some IDE users may welcome the ability to disable the automatic hover. You can do that by following these instructions:

  1. Press Ctrl+Shift+P to open the command palette.
  2. In the search field, type preferences.
  3. From the list of search results, click on “Settings: Open Preferences”.
  4. In the search field, type hover.
  5. Uncheck the box next to this setting:

    Enabled
    Controls whether the hover is shown.

  6. Close the Preferences tab in the IDE’s editor.

You will now find that the hover no longer appears automatically. When you do want the hover, you can trigger it with this sequence of keyboard shortcuts: Ctrl+K Ctrl+I . If you prefer a different keyboard shortcut, it can be customized in File > Advanced > Keyboard Shortcuts > Show Hover.

Thanks very much for the Hover info – very helpful! I think I’ll try changing the Hover delay time to 3 or 4 seconds rather than turn it off to see how that works – maybe “best of both worlds”. That should give me time to click where I want to make an edit which then seems to keep the Hover off during the edit, but still keep the Hover popup quickly available if I need it. I could not get the Ctrl+K Ctrl+I sequence to work once I turned the Hover off.

Al

Just a FYI item. I tried turning the Hover back on and setting the Hover display delay to 3000 milliseconds – didn’t work. And in fact, I can’t seem to turn the Hover back on at all, either through the Hover Preferences or using the Ctrl+K Ctrl+I sequence. However, until it’s fixed, better no Hover than Hover always on.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.