Twitter Library Fails - example too

I had good luck with twitter interfacing using BASIC authorization, but then of course discovered that Twitter has changed to oAuth approach and will kill BASIC this month. Great.

oAuth is much more complex and messy - so I tried to use the Twitter library in the playground area from NeoCat.

Does that work for anybody? Even just the little example loaded and running initially seems to post to Twitter okay (yes, I've got the token loaded), but it reports a failure with code '0' which doesn't mean much, and there's no verbosity to see what's actually going on.

It often doesn't post successfully either. Here's what I get:

connecting ... failed : code 0 connecting ... failed : code 0

For my sensor app I need to know if the tweet actually worked, or I don't know to try it again or cache it for later. Any success with this anyone?

FYI - an apparent path around the difficulties of oAuth. There's a promising looking oAuth proxy running at SuperTweet.net that seems to work for me. Unlike the Twitter library aforementioned, you can see the result of an attempt and thus parse to know whether you succeeded.

I'm still a little unsure of a bit of the API syntax, but it's working for me.

-Ross