TX constantly blinking?

Hi, I can't get the Arduino to work. (Like everybody else)

I currently got: Windows 7 (7100RC, 64x) FTDI drivers for Windows Vista 64x Arduino Mega TouchShield Slide

I first downloaded the arduino 0016 and 0012. Then when I connected the Arduino the LED13 started to blink. I tried to upload the blinking example, but there was an error for some reason. So I tried to manually reset the Arduino, but it didnt work. The LED13 was still blinking. Suddenly after a while with frustration I tried to reset. It blinked ones, the RX and TX blinked ones.

Then I tried to upload the code again. The TX was blinking so I thought it was working. After 5 minutes I thought otherwise and the computer had frozen. I looked around on the forum and tried to run the run.bat file. I uploaded again (and again and again). The TX still blinked and the software froze (not the computer). And when I exited the TX was still blinking.

I looked around some more, and found many with simular problems, just not the same. So I tried to update the FTDI, but didn't find anyone for Windows 7. So I tried Vista 64x. And still no result. So I don't know what to do.

Also. I don't know how to program the TouchShield. On 0012 I could choose TouchShield Slide as a board (obviously not working), but I can't on 0016. So what do I do with that?

Hope somebody can help!

Have you selected Arduino Mega from the boards menu?

Yes. Everthing in the software is set to what it should be.

Sorry for proposing things you have done before, but you have tried to upload the blink sketch without the shield connected?

Merkelig feil dette...

Yes. It's really wierd:) No shields, software as it should. But no result

Do you have a programmer nearby?

Maybe the bootloader is broken?

No I don't. I was thinking about that. I know that there is one, since it resets, but not if its the right one. Was hoping it was something else:)

The timing for manual reset can be quite tricky if you “just press” the button before you press upload.
Does the mega reset when you open a serial connection for the first time ?
If not its maybe one of those that got a bad dtr capacitor and auto reset is broken.

Well. The Mega blinks the same pattern when I connect it to the computer and when I manually reset it, if that's what you mean. (Except that the RX and TX blinks immediatly when I connect it to the PC)

well, when you plug in the usb cable it resets (L LED blinks) when it gets power for the first time. NORMAL. it also blinks, when you press the reset button manually. NORMAL. this still doesn't test if the auto-reset actually works though. a few days ago there was a thread about mega boards with a wrong auto-reset capacitor and therefore not working uploads.

the board should also reset if you do this:

  • plug in the board (it will reset)
  • start the arduino software and select the proper serial port
  • open the serial monitor (it should reset)

if the board doesn't reset if you start the serial monitor, auto-reset doesn't work.

Hmm.. I tried it. It doesn't seem to reset when the software starts. And when I serial monitor, the TX just starts blinking (even after I stopped it). So it is possible that that could be a problem:)

Edit: I just remembered that the LED 13 was blinking the blinking example before I tried to reset it when I got it. And on the TouchShield there was already a program on. So I think that there was allready a program on when I got it. In my head that means that it can upload (but I don't know)