TX pin not glowing

I’m trying to use RFID reader along with a keypad in the following manner:

In a normal line follower,
On pressing 2 in the keypad at a T junction the robot takes left.
On pressing 4 in the keypad at a T junction the robot takes right.

On showing the RFID tag it must stop.

Problem faced:
Keypad is working perfectly but though the tag is getting detected by the RFID reader, the robot is not stopping. TX LED on the board was OFF.

Without line follower, I tried simply going straight on pressing 2 and RFID to stop, IT WORKED. TX LED on the board was ON.

What is the possible problem?

You have to understand that most people don't have a line following RFID reading keypad operated robot with a TX LED. So you have to provide more details. :slight_smile: Code would help, in code tags please, yadda yadda yadda...

I would think that not having pins glow would be a good thing, LEDS, now that's a different situation. TX LED not on, TX is Logic low.

next question?

"TX LED on the board was OFF."
On which board? On the Arduino, that will only turn on during USB transfers.

Thank you all. There was a mistake in my code.