U boot stops at fuse init api

Hello

When i run serial terminal, open the com port and hit the reset button to see startup process, the dump always ends at the fuse init api. At approximately 40 seconds. Should i be concerned? I've seen some u-boot go on for 2000 seconds in this forum. (running dmesg | tail etc) I also get the message "problem last time I tried configuring wireless network" when opening arduino.local. Is there a relation?

Thanks for any help. vince

That is well past uboot. It is the last step in the boot process before the wifi starts for me so I imagine the wifi is never coming up. It probably doesn't like something about your wireless configuration.

Try this:http://playground.arduino.cc/Hardware/Yun#restoring_a_yun

noblepepper

The WiFi is working… got 2000 hits with the TemperatureWebPanel thru WiFi and Yun can be seen
on an Android phone. Everthing seems to be ok outside of getting “problem last time I tried configuring wireless network” message and Serialterminal stopping at fuse init .

Thanks for you help

login as: root
root@192.168.240.1’s password:

BusyBox v1.19.4 (2013-08-07 16:16:02 CEST) built-in shell (ash)
Enter ‘help’ for a list of built-in commands.


/_\ ___ /_\ ___ /_\ /\
/:confused: / /\ \ /::expressionless: | /\ \ /::expressionless: | /::\
/:confused: / :\ \ /:|:| | :\ \ /:|:| | /:/:\
/:confused: / /::_
\ /:/|:| |__ /::_\ /:/|:| |__ /:confused: :\
/:/__/ /:/// /:confused: |:| /_
\ /:/// /:confused: |:| /_\ /:/__/ :_
:\ \ //:confused: / /|:|/:confused: / //:confused: / /|:|/:confused: / :\ \ /:confused: /
:\ \ ::confused:/ |:/:confused: / ::confused:/ |:/:confused: / :\ /:confused: /
:\ \ :_\ |::confused: / :_\ |::confused: / :/:confused: /
:__\ // /:confused: / // /:confused: / ::confused: /
// // // //


| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -| || | | || || |
|
_____|| |
||||___||| |____|
|
| W I R E L E S S F R E E D O M

root@Yun1Port17:~# ls -la /mnt/www
ls: /mnt/www: No such file or directory
root@Yun1Port17:~# ls -la /mnt /www
/mnt:
drwxr-xr-x 1 root root 0 Aug 8 16:31 .
drwxr-xr-x 1 root root 0 Aug 8 15:57 …
lrwxrwxrwx 1 root root 9 Aug 8 16:31 sd → /mnt/sda1
drwxr-xr-x 14 root root 16384 Dec 31 1969 sda1

/www:
drwxr-xr-x 1 root root 0 Aug 8 16:31 .
drwxr-xr-x 1 root root 0 Aug 8 15:57 …
drwxr-xr-x 2 root root 27 Aug 19 10:22 cgi-bin
-rw-r–r-- 1 root root 436 Jul 30 2013 index.html
drwxr-xr-x 2 root root 53 Aug 19 10:22 keystore_manager_exampl e
drwxr-xr-x 4 root root 61 Aug 19 10:21 luci-static
lrwxrwxrwx 1 root root 21 Aug 8 16:31 sd → /mnt/sda1/arduino /www
root@Yun1Port17:~# dmesg | tail
[ 41.120000] cfg80211: (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 41.120000] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[ 41.590000] NTFS driver 2.1.30 [Flags: R/O MODULE].
[ 41.660000] Error: Driver ‘gpio-keys-polled’ is already registered, aborting…
[ 41.710000] PPP generic driver version 2.4.2
[ 41.910000] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 42.450000] NET: Registered protocol family 24
[ 42.490000] nf_conntrack version 0.5.0 (955 buckets, 3820 max)
[ 43.240000] Linux video capture interface: v2.00
[ 43.500000] fuse init (API version 7.20)
root@Yun1Port17:~# dmesg | tail
[ 41.120000] cfg80211: (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 41.120000] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[ 41.590000] NTFS driver 2.1.30 [Flags: R/O MODULE].
[ 41.660000] Error: Driver ‘gpio-keys-polled’ is already registered, aborting…
[ 41.710000] PPP generic driver version 2.4.2
[ 41.910000] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 42.450000] NET: Registered protocol family 24
[ 42.490000] nf_conntrack version 0.5.0 (955 buckets, 3820 max)
[ 43.240000] Linux video capture interface: v2.00
[ 43.500000] fuse init (API version 7.20)
root@Yun1Port17:~#

On my Yun the fuse init (API version 7.20) is the last thing before the messages about wifi associating with my local network, since you are not seeing those in the output of dmesg I think you must be running the Yun in AP mode.

I haven’t seen the “problem last time I tried configuring wireless network” message but it looks like it is triggered by something in the logs. Where do you see this?

If your wifi is working what is your problem?

Can you connect to the YunSerialTerminal sketch through USB and a terminal program (putty, picocom, minicom)?

What does cat /tmp/lastlog output?

What does the kernel log and system log in Luci show?

What does /etc/init.d/network restart output?

Hello Noblepepper

“On my Yun the fuse init (API version 7.20) is the last thing before the messages about wifi associating with my local network, since you are not seeing those in the output of dmesg I think you must be running the Yun in AP mode.”

Correct, I’m running in AP mode

“I haven’t seen the “problem last time I tried configuring wireless network” message but it looks like it is triggered by something in the logs. Where do you see this?”

See attached jpg

"What does Code:cat /tmp/lastlog output?

root@Yun1Port17:~# cat /tmp/lastlog
cat: can’t open ‘/tmp/lastlog’: No such file or directory

“What does Code: /etc/init.d/network restart output?”

root@Yun1Port17:~# /etc/init.d/network restart
Configuration file: /var/run/hostapd-phy0.conf
Using interface wlan0 with hwaddr 90:a2:da:f1:00:86 and ssid "ArduinoF10086"

Thanks for any help
vince

Hi.

I don't know if anyone's still interested in an answer but i'm posting it anyway for future reference, hoping it helps others.

I had the same problem, but my problem started when i tried to disable the wifi. Here's what i did: among other things, in the luci interface (advanced mode) i went to "Network / Wifi" and i disabled the wifi. After that every time Yun restarted, the wlan blue led started blinking after "fuse init", then the message "Removing MTD device #3 (rootfs_data) with use count 1" appeared and Yun restarted.

What i did to correct the issue? Well, at the point the wlan blue led started blinking, Yun's web UI was up and running, so i went to "Network / Wifi" and i re-enabled the wifi. That did the trick.

Sensitive little Yun...

Please read this http://playground.arduino.cc/Hardware/Yun#disable_wifi