u8glib T6963 240x128 low fps normal ??

HI all,

started to get a menu system going and realised the draw loop is way too slow to let me do anything else like run radio communication ...

with the fps test sketch i get:

draw: 1.1 fps draw pixel 0.2 fps draw clip test: 2.4 fps clear screen: 0.6 fps

is this just the display i bought ? i imagine so .... anything i can do beside buy a new one ?...

btw im running on a mega with this config:

U8GLIB_T6963_240X128 u8g(49, 48, 47, 46, 45, 44, 43, 42, 37, 36, 35, 34, 33);

Well... yes, I agree, it is slow. U8glib is optimized for SPI displays and low RAM consumption.

Oliver

thanks for the reply and great library, this speed would be just ok if the display is all you had too do.... and theres lots of great features particularly including M2klib

so i decided to look again at the old library here: https://code.google.com/p/arduino-t6963c/

it is (i imagine) designed from ground with native support for this controller in mind, and it performs that way too i found out.

the u8glib hello world example takes 408 milliseconds to complete one loop

void loop(void) {
  unsigned long time = millis();
  // picture loop
  u8g.firstPage();  
  do {
    draw();
  } while( u8g.nextPage() );
  
  // rebuild the picture after some delay
  Serial.println(millis() - time);
  delay(500);
}

but the t6963c library with code that does the same thing (print hello world) takes at most 1 millisecond, sometimes none... ]:D

void loop(){
   
unsigned long time = millis();

 LCD.TextGoTo(0,0);
 LCD.writeString("Hello World");

 Serial.println(millis() - time);
 delay(1000);
}

i will fork arduino-t6963c and try adding some more features as i need