UART doesn't work

Hello!
I have an issue with an Arduino UNO board.
I cannot upload sketch using USB (i.e. UART).I don't know how it happened, but initially it was working quite well.
I tried to upload a sketch using SPI and it works perfectly. I also have changed a microcontroller with no result.
I tried to use USB connection on other computer as well.
I have another Arduino UNO board and it works with USB (so it seems that my computer works well).
One thing that might be a clue (but I'm not sure):
I uploaded a simple sketch which sends a "Hello" message through UART, and the terminal shows only "He".
Any thoughts about my issue?

If you have uploaded a sketch via SPI, the bootloader has been erased - you need to connect the ISP programmer again, select Arduino Uno as the board, and then choose Tools -> Burn Bootloader to put the bootloader back.

Also, be sure to disconnect anything you have that might be connected to pins 0, 1 or reset when uploading via serial - those pins are used for uploading, and external devices connected to them will interfere with uploads.

Thanks a lot DrAzzy! It works.
To be honest, I didn't know about that.
As to issue with "Hello" message - I've found out the problem.

melyoha:
As to issue with “Hello” message - I’ve found out the problem.

It’s always nice to share what the problem was so others can learn from it.

sterretje:
It's always nice to share what the problem was so others can learn from it.

It was pretty simple: I forgot to add sei() command so there were no interruptions (UART needs them).