ubuntu 12.04 & arduino 0022

salve a tutti, ho aggiornato da poco ubuntu all'ultima versione e vorrei poter usare la versione 0022 dell'IDE, prima avevo la 10.04 di ubuntu e andava tutto bene... ricordo che Leo in una discussione di qualche mese fa mi aveva detto che con le versioni successive alla 10.04 c'erano problemi con l' "avr-g++"... io volevo capire se era possibile per risolvere questo problema senza grosse complicazioni... grazie in anticipo ;)

Ciao, non per pignoleria ti devo correggere: funziona fino alla 11.04 compresa, non 10.04 Se dalla 12.04 fai un downgrade, metti la 11.04

purtroppo non abbiamo un elenco di problemi noti con le varie versioni... l'unica è che tu provi io (arch linux) ho dovuto modificare dei file, ma questa cosa mi impalla tutte le versioni dell'ide, quando provo a compilare mi dice(va):

In file included from /usr/lib/gcc/avr/4.7.0/../../../../avr/include/util/delay.h:44:0,
                 from /usr/lib/gcc/avr/4.7.0/../../../../avr/include/avr/delay.h:37,
                 from ~/arduino-0022/hardware/arduino/cores/arduino/wiring_private.h:30,
                 from ~/arduino-0022/hardware/arduino/cores/arduino/WInterrupts.c:34:
/usr/lib/gcc/avr/4.7.0/../../../../avr/include/math.h:426:15: error: expected identifier or '(' before 'double'
/usr/lib/gcc/avr/4.7.0/../../../../avr/include/math.h:426:15: error: expected ')' before '>=' token

@ER: tutte le distribuzioni, aggiornandosi, hanno adottato versioni più recenti della toolchain, versioni che hanno tutte più o meno dei bug. L'unica è non aggiornare oppure provare (per chi ha Ubuntu) ad installare la toolchain patchata presentata su Avr-Freaks:

@ER e lesto: nella discussione che aprii settimane fa sull'aggiornamento della toolchain su Linux troverete cose utili: ER, il link alla discussione dove c'è la toolchain patchata lesto, alcuni consigli e file su come risolvere i problemi della compilazione della toolchain su Arch

il problema è che di ste robe ci capisco poco :sweat_smile: comunque grazie adesso guardo ;)

domani torno a forlì dove ho il pc con ubuntu

quindi posso provare a dare un'occhiata magari si trova un vecchio repo con la vecchia versione che gira anche con 12.04..

magari domani riesco a fare qualcosam vi faccio sapere.

altrimenti provo con avr freaks ;)