ubuntu 20.04 python $PATH error

Good day gentle people

So after upgrading from Ubuntu 18.04 LTS to 20.04 both Arduino IDE and Arduino Pro gives me: "exec: "python": executable file not found in $PATH Error compiling for board ESP32 Wrover Module" - same with all ESP32.

Tried reinstalling, currently on 1.8.11. Read for two days and tried tons of different things, including guides:

https://github.com/espressif/arduino-esp32/blob/master/docs/arduino-ide/debian_ubuntu.md https://github.com/espressif/arduino-esp32/blob/master/docs/arduino-ide/boards_manager.md

Python3 and bunch others installed.

Nothing helps...

Hello, I am using Arduino IDE running on Manjaro Linux and I also get that error message when compiling. Try uninstalling the IDE and reinstalling it again, but without positive results. In another forum, someone tried:

sudo apt install python

Please if anyone has a solution, share it.

regards

Hi, there!

I have got the exactly same problem. I also did sudo apt install python. Got back this:

Reading package lists… Done
Building dependency tree
Reading state information… Done
python is already the newest version (2.7.15~rc1-1).
0 modernizētas, 0 instalētas no jauna, 0 tiks noņemtas un 6 netiks modernizētas.

When I type Python in Terminal, got this back:

Python 2.7.17 (default, Nov 7 2019, 10:07:09)
[GCC 7.4.0] on linux2
Type “help”, “copyright”, “credits” or “license” for more information.

Looking forward for solution.

P.S. I tried to use ESP8266 and it compiles, it uses different directories, of course and it seams to me that something might be wrong with WiFi library, can cannot figure out what is that. ESP8266 uses ESP8266WiFi library and it works…

Thank you!
BR,
Valters