Ubuntu Does not Recognize Uno When it is Sending Serial Data

Hello there, I recently installed Ubuntu 11.04, and from there used the package manager to download/install the arduino package. I did not download anything else. I then got started on programming my Uno. It worked fine uploading the blink and digitalReadSerial example sketchs, but when I tried to read the Serial data, it said it could not find the serial port. I went to tools, but there were no serial ports listed. I could not upload a new sketch either.

I found I could upload a sketch by holding down the reset button, plugging in the arduino, pressing the upload button, and then releasing the reset when the Rx LED blinks, but that is a major pain.

Summary: Ubuntu 11.04 (installed a few days ago, only downloaded Chromium, Arduino and recommended packages) (dual boot with Windows XP). Arduino Uno, fully working Arduino 0022, installed with Synaptic package manager Can upload when no serial data is sent back, can't find serial port when data is being sent back (on same USB port, same session, etc.) Can upload/etc. on Windows.

yes it's a common problem with 0022 and ubuntu. Not solved yet. What you can try so far is running the software as root. Also check this thread for updates: http://arduino.cc/forum/index.php/topic,63744.0.html

it's a common problem with 0022 and ubuntu

I just put together/fixed a HP g60-535DX laptop. I download the Ubuntu 11.04 64bit iso image, install it, upgrade it to the newest kernel (2.6.38-10-generic) and applications. Installed arduino via apt-get and it works great. I would suggest upgrading the kernel to version 2.6.38-10. You can check the kernel version by executing an "uname -r". note: I have only tested the on the Diecimila. I have an old old laptop with the ubuntu 11.04 32bit that I will test today. Works on 32bit version, same kernel version.