ULN2803a

Mahlzeit =)

Ich habe hier ein kleines Problem mit dem ULN2803a.

Ich versuche damit (wie in einem anderen Thread schon beschrieben) 4 Pumpen laufen zu lassen. Den ULN steuere ich mit einem 74HC595 an.

Ich habe also 2 Stromkreise. 1x 5V für den YUN / 74HC595 / RTC 1x 12V für die Pumpen

Am ULN sind ja "links" die Eingänge und "rechts" die Ausgänge. Die Pumpen hängen an +12V und die Masse geht zum ULN.

An Pin 9 muss ja Masse und an Pin 18 Spannung

Welche nehme ich da? 5V oder 12V?

Achso... rein von der Logik her würde ich sagen 12V, allerdings rennen dann immer alle Pumpen wenn ich auch nur einen Pin auf high setze...

Pin 18 ist der Ausgang vom 1. Treiber. Nix Spannung. Wenn du induktive Lasten, eben Motoren Pumpen und sowas, dran hängen hast, kannst du die +12V an Pin 10 hängen...

Ach vertan....

Hier ein Bild:

Ich habe an 9 Masse vom 12V und an 10 natürlich Spannung vom 12V.

Habe jetzt auch mal ohne Spannung an 10 probiert... gleiches Phänomen.

An die Masse Pin 9 muss natürlich sowohl die Masse vom Arduino, wie auch die Masse von den 12V.

Ah? Ok... teste ich mal...

Boah ich liebe dieses Forum =)

Rennt... deswegen waren wohl auch high und low verstauscht. Ist das erste mal das ich den ULN einsetze...

GANZ HERZLICHEN DANK WILLIE!!!!

Ich rate Dir vom ULN2803 ab da dieser bei gleichzeitigen Einschalten mehrer Ausgänge sehr viel weniger Strom als die 0,5A liefern kann. Ich rate dir den ULM2068 zu nehmen. Auf dem COM pin des ULN2803 sind die Kathoden der Freilaufdioden aller Ausgänge geschalten. Es ist kein Pin für die Spannungsversorgung für nicht induktive Lasten kann das Pin auch nicht mit der Versorgungsspannung der Last verbunden werden (in Deinem Fall 12V). Grüße Uwe

Naja, du kannst schon die 500mA ziehen, aber eben nur insgesamt, da nur ein gemeinsamer Masseanschluss da ist. D.h. wenn du 2 Pumpen mit 300mA hast, mußt du sicher stellen, daß nicht beide Pumpen gleichzeitig laufen. Ich persönlich würde aber an einen 2803 gar keinen Motor anschliessen. Denn da ist man schnell mit dem Anlaufstrom auch über die 500mA. Auch die 1,5A meines Vorredners sind da schnell erreicht. Ich würde eher mit dem ULN Relais schalten, die dann wieder die Pumpen schalten.

Pumpe wird immer nur eine gleichzeitig laufen, das hatte ich schon bedacht.

Anlaufstrom der peristaltikpumpen hab ich mit 400mA gemessen (alle 4 einzeln gemessen, jeweils 10 mal. höher kamen sie nicht). Wenn sie läuft sinds 180-200mA (bissel abweichung zwischen den pumpen).

Ich wollte erst Relais nehmen (hatte ich auch schon drin), aber das wäre dann doch zuviel geworden. Jede Pumpe läuft einmal pro stunde für 2 Minuten.

Hat auch erst an eine transistorschaltung gedacht, aber der uln erschien mit in diesem fall die schönste wahl.

Da ich nen sockel verlötet habe kann ich den aber noch austauschen ohne großen akt.