Una dritta per problema di alimentazione (credo)

Ciao,
oggi ho ripreso in mano un 'aggeggio' che prende la temperatura e la trasmette in RF. Dovevo fare qualche modifica software.
E' un clone UNO R3.
Faccio un paio di giri di prova e va tutto bene. Rimetto la scheda fili etc nel case di plastica e collego ad alimentatore. Non va, la temperatura segnata varia da 77.10 a 77.80
Mi dico "al solito qualche cavo si è schiacciato/sfilato/cos'altro".
Smonto e ricollego al pc. Temperatura di nuovo ok. Collego alimentatore (9v 1A): 77 e rotti.
Cambio alimentatore con uno nuovo (sempre a 9V 1A): stessa storia.
Collego a USB del pc: temperatura corretta.
Collego a USB di un power bank: temperatura corretta:
Penso che ci sia un problema nella presa del jack, prendo altro clone UNO R3 (nuovo), stacco e riattacco i cavi, upload dello sketch: problema identico.
Allora creo uno sketch che contiene solo la lettura della temp ogni sec e la scrive su Serial, lo carico e provo prima con la usb da pc (temperatura regolare su serial monitor), poi attacco l'alimentatore e leggo 77.20 e nient'altro. Presumo che dopo la prima lettura si inchiodi tutto.

E' un problema hardware, ma quale? Possibile che lo faccia sostituendo alimentatore e scheda?

Il problema é che non siamo veggenti e percui non possiamo indovinare lo sketch e che sensore stai usando.
Ciao Uwe

Si, messa così è criptica, ma ho poi risolto. Visto che non era normale che il problema persistesse con cambio scheda e alimentatore, l'unico punto debole poteva essere la millefori con connessione 3 fili ds18b20 + resistenza + connessione hc12 + condensatore di decoupling, data la maestria delle mie saldature. Dissaldato tutto e rifatto. Problema sparito.

silvioz:
Si, messa così è criptica, ma ho poi risolto. Visto che non era normale che il problema persistesse con cambio scheda e alimentatore, l'unico punto debole poteva essere la millefori con connessione 3 fili ds18b20 + resistenza + connessione hc12 + condensatore di decoupling, data la maestria delle mie saldature. Dissaldato tutto e rifatto. Problema sparito.

E come potevamo indovinarlo?
Ciao Uwe

uwefed:
E come potevamo indovinarlo?
Ciao Uwe

Uwe, sei sempre il solito … e’ una vita che ti diciamo di usare le batterie nucleari, per la sfera di cristallo, perche le altre normali si scaricano troppo in fretta … :smiley:

uwefed:
E come potevamo indovinarlo?
Ciao Uwe

Non potevate, ovviamente.
Neanche allegando una BOM , uno schema, e lo sketch. O una sfera di cristallo.