Unable to burn Bootloader

Hello,

Tried troubleshooting this off the web but I'm out of ideas. I have a project with a custom PCB and an ATMeaga328P-AU on it. I have not been able to burn the bootloader no matter what I try. I keep getting the error below. In order to try and isolate the problem I tried using the same NANO as an ISP as I was before to update the bootloader of another arduino NANO, same issue. I then tried a different Arduino as the programmer, same result. I've tried two different computers with different revisions of the Arduino IDE on them and one of them running linux. I even tried loading a bootloader to a bare bones ATTiny85 which I know I've done before for other projects. I have no idea what is causing the problems I see. The connections are solid I, physically checked them and changed breadboards I was using just to be sure.

Does anyone have any other ideas?

Thanks Again.

Error message from upload

Arduino: 1.8.9 (Windows 10), Board: "Arduino Nano, ATmega328P"

C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM9 -b19200 -e -Ulock:w:0x3F:m -Uefuse:w:0xFD:m -Uhfuse:w:0xDA:m -Ulfuse:w:0xFF:m

avrdude: Version 6.3-20171130
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM9
Using Programmer : arduino
Overriding Baud Rate : 19200
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x15
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x15
AVR Part : ATmega328P
Chip Erase delay : 9000 us
PAGEL : PD7
BS2 : PC2
RESET disposition : dedicated
RETRY pulse : SCK
serial program mode : yes
parallel program mode : yes
Timeout : 200
StabDelay : 100
CmdexeDelay : 25
SyncLoops : 32
ByteDelay : 0
PollIndex : 3
PollValue : 0x53
Memory Detail :

Block Poll Page Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack


eeprom 65 20 4 0 no 1024 4 0 3600 3600 0xff 0xff
flash 65 6 128 0 yes 32768 128 256 4500 4500 0xff 0xff
lfuse 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
hfuse 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
efuse 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
lock 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
calibration 0 0 0 0 no 1 0 0 0 0 0x00 0x00
signature 0 0 0 0 no 3 0 0 0 0 0x00 0x00

Programmer Type : Arduino
Description : Arduino

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x14

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x02

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x10
Hardware Version: 4744608
Firmware Version: 0.4611299
Topcard : STK502
Error while burning bootloader.
Vtarget : 1.8 V
Varef : 0.0 V
Oscillator : Off
SCK period : 0.1 us

avrdude: stk500_initialize(): (b) protocol error, expect=0x10, resp=0x01
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x10

avrdude done. Thank you.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Do you have a 10 uF capacitor connected between the reset and ground pins on the Arduino board you're using as an ISP programmer?

I didn't, once I did I was able to get things working again. Thanks a ton for the tip.

You're welcome. I'm glad to hear it's working now. Enjoy!
Per

Thanks again, thats a weird bug to run into an none of the online tutorials mention it so im glad you helped me out. im pretty sure i had similar issues a while ago and didnt remember the fix so sorry if it was kind of a repost.

Sometimes you can get away without using the capacitor so that's why you'll often see tutorials where it's not used (even in Arduino's official tutorial they show it on the Mega, but not on the Uno for some strange reason). Arduino recently made a change to the Arduino as ISP programmer definition that makes it much more likely that you will need the capacitor so a lot more people are running into this problem now. I reverted that change to the programmer definition a while ago but Arduino has not released a new version of Arduino AVR Boards since then, so it hasn't become publicly available yet.