Unable to code an arduino

Hi,

So, I've been using arduino for a long long time. And it worked fine. Suddenly today I was uploading code like normal to debug one of my apps. I uploaded, and it gave a timeour error. I tried multiple times, reinstalled, etc etc everything you'd normally do, and it refused to work.

What happens is pretty weird : It compiles. It starts uploading (RX/TX flicker) And somewhere in between RX/TX stops glowing completely, and After a second, I get an error on Arduino stating timeout error.

I tried with Arduino 1.0.4, 1.5.4. I tried it with another laptop, it worked fine. I thought maybe it was a coding error on my part somehow, but even BareMinimum or Blinky won't work.

My laptop recognizes it fine, and it starts uploading, but always gies timeout in between. "dmesg" in terminal shows it is detected, it appears in Tools > SerialPort also, I've chosen the correct board (Mega 2560). Suddenly it 's giving an error, I didnt even install anything new.

Could someone please help em out quickly ? I'm at a standstill cuz of it.

Code? Any eccentric punctuation?

but even BareMinimum or Blinky won't work.

So if simple stuff won't load then either the boot loader needs reblowing, or the processor's memory is toast.

Regarding any weird punctuation, I doubt it, the exact same code works on another laptop. And even blink doesnt work on mine !

Regarding memory screwed/any other issue. My code uses 5% on my arduino mega 2560. It works on another laptop. Arduino is prefectly fine. In fact using the other laptop I uploaded it nearly 20 times with no issues, I even finished debugging my code, but still cannot upload with my laptop !_!

Btw, I forgot to mention: i'm using Ubuntu 12.04

There is a lot you did not mention. So it is your laptop that is screwed. Normally it is a driver issue when this happens especially with Linux, I find Linux is very unstable in general.

I see, okay, i've never faced a driver issue in ubuntu.

Could you explain what I could do for this ?

I find windows has more driver problems than ubuntu, and know how to troubleshoot them. But as ubuntu has never had a problem (for me) I have no idea how to fix this.

Sorry I am not a Linux guy, I hate it nearly as much as I hate windows.