Unable to communicate between Arduino 101 and MIT app inventor (My new cellphone (Motorola G9 power) doesn´t seem to catch the LED service)

Hi everyone, Im texting this because I have been unable to stablish communcation between my cellphone and the board I am using (Arduino 101).

Just to check connection and communication of my devices by BLE I tried to use the LED control example of Arduino 101 and App Inventor (in arduino is the code of CurieBLE Callback LED example) setting the board as a peripheral, Simple stuff it seems... But when I tried to push te bttn and control de LED nothing happened, I tried to check the connection with the same example but using nRF Connect instead of App Inventor, in which they control the LED just writing a "1" in the characteristic properties of writable in the nRF connect. But when I connected the devices it looked different from the example. In the example it showed the title "Unknown service" and the UUID: 19B10000-E8F2-537E-4F6C-D104768A1214 (that corresponds to the LED service)


Like this...

but when I connected m cellphone with the borad usingg nRF Connect app it showed me "Battery service" and its UUID (0x180F), no the "Unknown service" it should show lie the example before, this service doesn´t even have writable properties, it wont let me write the "1" to turn on the LED (and definetly is not the service im setting on the board).
(shown in thhe picture i repl after this)

To sum up my cellphone is not getting the service that im setting on the code, is getting "Battery service" so I cant communicate with the board to control the LED.

So I went to a friends lab to reasearch for the problem, and it turns out that this only happened with my cell phone, we use the same App Inventor-Arduino101 LED example with other phones (Androids) and it worked perfectly as well as the nRF connect example.... I really dont know what is happening, my friends cellphone had the same version of android than me, and the other cellphones we used as well! Ive tried rebooting my cellphone, Bluetooth, deleting Bluetooth caché, and it still doesnt work.
And this is the error that the apk LED from App Inventor shows when I try to control de LED. (Picture shown below)
The weird thing is that it looks like the connection succeeds but not the communication.

Does 911 have a section handling questions like this?
Your question, for an advanced project, lacks everything. You need to do better.

@Railroader Instead of making fun or critizing you could offer a positive recommendation for everthing you think my project or my question lacks, and it would be very welcoming.

Read the first topics telling how to use this forum, how to get the best from this forum.
There's just not enough of facts, information, in Your question to give any help.

when I connected it showed me "Battery service"

Posting a wiring diagram? Code?

@Railroader Thank you for answering me, I edited my question with more facts, hope its more understandable.

@Railroader This is the picture that shows m cellphone connected (via BLE) to the nRF Connect app using the same example that should work for mit App Inventor to control a LED with Arduino 101 BLE, the code I used is "Callback LED" from the CurieBLE examples.

Sorry. I'll not make things harder for You so I leave the question.
Working with military as well as space projects I know what documentation looks like. Adding more words to a word sallad doesn't help.
Good luck, I'm out.