Unable to compile basic send sms program given on arduino.cc

Basic code to send sms in learning section of Arduino.cc
/*
SMS sender

This sketch, for the Arduino GSM shield,sends an SMS message
that you send it through the serial monitor. To make it work,
open the serial monitor, and when you see the READY message,
type a message to send. Make sure the serial monitor is set
to send a newline when you press return.

Circuit:

  • GSM shield

created 25 Feb 2012
by Tom Igoe

This example is in the public domain.
*/

// libraries
#include <GSM.h>

#define PINNUMBER “”

// initialize the library instance
GSM gsmAccess; // include a ‘true’ parameter for debug enabled
GSM_SMS sms;

void setup()
{
// initialize serial communications
Serial.begin(9600);

Serial.println(“SMS Messages Sender”);

// connection state
boolean notConnected = true;

// Start GSM shield
// If your SIM has PIN, pass it as a parameter of begin() in quotes
while(notConnected)
{
if(gsmAccess.begin(PINNUMBER)==GSM_READY)
notConnected = false;
else
{
Serial.println(“Not connected”);
delay(1000);
}
}

Serial.println(“GSM initialized”);
}

void loop()
{

Serial.print("Enter a mobile number: ");
char remoteNumber[20]; // telephone number to send sms
readSerial(remoteNumber);
Serial.println(remoteNumber);

// sms text
Serial.print("Now, enter SMS content: ");
char txtMsg[200];
readSerial(txtMsg);
Serial.println(“SENDING”);
Serial.println();
Serial.println(“Message:”);
Serial.println(txtMsg);

// send the message
sms.beginSMS(remoteNumber);
sms.print(txtMsg);
sms.endSMS();
Serial.println("\nCOMPLETE!\n");
}

/*
Read input serial
*/
int readSerial(char result)
{
int i = 0;
while(1)
{
while (Serial.available() > 0)
{
char inChar = Serial.read();
if (inChar == ‘\n’)
{
result = ‘\0’;

  • Serial.flush();*
  • return 0;*
  • }*
  • if(inChar!=’\r’)*
  • {*
    _ result = inChar;_
    * i++;*
    * }*
    * }*
    * }*
    }
    these errors been seen
    C:\Users\Hp\Desktop\Arduino\arduino-1.0.6\libraries\GSM\GSM3ShieldV1ModemVerification.cpp: In member function ‘String GSM3ShieldV1ModemVerification::getIMEI()’:
    C:\Users\Hp\Desktop\Arduino\arduino-1.0.6\libraries\GSM\GSM3ShieldV1ModemVerification.cpp:72: error: conversion from ‘int’ to ‘String’ is ambiguous
    C:\Users\Hp\Desktop\Arduino\arduino-1.0.6\hardware\arduino\cores\arduino/WString.h:61: note: candidates are: String::String(const __FlashStringHelper*)
    C:\Users\Hp\Desktop\Arduino\arduino-1.0.6\hardware\arduino\cores\arduino/WString.h:59: note: String::String(const char*)
    then I went to
    GSM3ShieldV1ModemVerification::getIMEI() and checked then return type was string and returned value was NULL thats why this error came so I changed NULL with a constant string
    and compiled again but now I am getting following
    C:\Users\Hp\Desktop\Arduino\arduino-1.0.6\libraries\GSM\GSM3ShieldV1ScanNetworks.cpp: In member function ‘String GSM3ShieldV1ScanNetworks::getCurrentCarrier()’:
    C:\Users\Hp\Desktop\Arduino\arduino-1.0.6\libraries\GSM\GSM3ShieldV1ScanNetworks.cpp:66: error: conversion from ‘int’ to ‘String’ is ambiguous
    C:\Users\Hp\Desktop\Arduino\arduino-1.0.6\hardware\arduino\cores\arduino/WString.h:61: note: candidates are: String::String(const __FlashStringHelper*)
    C:\Users\Hp\Desktop\Arduino\arduino-1.0.6\hardware\arduino\cores\arduino/WString.h:59: note: String::String(const char*)
    C:\Users\Hp\Desktop\Arduino\arduino-1.0.6\libraries\GSM\GSM3ShieldV1ScanNetworks.cpp: In member function ‘String GSM3ShieldV1ScanNetworks::getSignalStrength()’:
    C:\Users\Hp\Desktop\Arduino\arduino-1.0.6\libraries\GSM\GSM3ShieldV1ScanNetworks.cpp:85: error: conversion from ‘int’ to ‘String’ is ambiguous
    C:\Users\Hp\Desktop\Arduino\arduino-1.0.6\hardware\arduino\cores\arduino/WString.h:61: note: candidates are: String::String(const __FlashStringHelper*)
    C:\Users\Hp\Desktop\Arduino\arduino-1.0.6\hardware\arduino\cores\arduino/WString.h:59: note: String::String(const char*)
    again here problem is return type is string and returned value NULL
    can anybody help with this or any link to download corrected libraries

Does anybody faced this issue....please help asap

i have the same problem!!!please someone help us...

Don't use version 1.0.6 until the problem is sorted.

http://arduino.cc/en/Main/OldSoftwareReleases

Use version 1.0.5