unable to compile with mac os 10.7.5

fresh install and have loaded any needed libraries, when i try to compile it errors every time for any board. I found a thread that had me do a few terminal commands to load a library of some kind but didnt help.

Arduino: 1.8.2 (Mac OS X), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

fatal error: runtime: bsdthread_register error (unset DYLD_INSERT_LIBRARIES)

runtime stack:
runtime.throw(0x183b20, 0x3f)
/home/jenkins/go/src/runtime/panic.go:566 +0x95 fp=0x7fff5fbff700 sp=0x7fff5fbff6e0
runtime.goenvs()
/home/jenkins/go/src/runtime/os_darwin.go:86 +0x85 fp=0x7fff5fbff730 sp=0x7fff5fbff700
runtime.schedinit()
/home/jenkins/go/src/runtime/proc.go:450 +0x9c fp=0x7fff5fbff770 sp=0x7fff5fbff730
runtime.rt0_go(0x7fff5fbff7a8, 0x1b, 0x7fff5fbff7a8, 0x0, 0x1000, 0x1b, 0x7fff5fbff960, 0x7fff5fbff998, 0x7fff5fbff9a4, 0x7fff5fbff9b4, ...)
/home/jenkins/go/src/runtime/asm_amd64.s:145 +0x14f fp=0x7fff5fbff778 sp=0x7fff5fbff770
/Applications/Arduino.app/Contents/Java/arduino-builder returned 2

Error compiling for board Arduino/Genuino Mega or Mega 2560.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

I am having a very similar issue... I found this suggestion, but it did not fix the error: fatal error: runtime: bsdthread_register error (unset DYLD_INSERT_LIBRAR - Installation & Troubleshooting - Arduino Forum

I am using:
Mac OS 10.11.6
Arduino IDE 1.8.4

When I try to VERIFY the Blink example (for Uno) I get the following error:

fatal error: runtime: bsdthread_register error

runtime stack:
runtime.throw(0x18113e, 0x21)
/home/jenkins/go/src/runtime/panic.go:566 +0x95 fp=0x7fff5fbff730 sp=0x7fff5fbff710
runtime.goenvs()
/home/jenkins/go/src/runtime/os_darwin.go:88 +0xa0 fp=0x7fff5fbff760 sp=0x7fff5fbff730
runtime.schedinit()
/home/jenkins/go/src/runtime/proc.go:450 +0x9c fp=0x7fff5fbff7a0 sp=0x7fff5fbff760
runtime.rt0_go(0x7fff5fbff7d8, 0x17, 0x7fff5fbff7d8, 0x0, 0x0, 0x17, 0x7fff5fbff990, 0x7fff5fbff9c8, 0x7fff5fbff9d4, 0x7fff5fbff9e4, ...)
/home/jenkins/go/src/runtime/asm_amd64.s:145 +0x14f fp=0x7fff5fbff7a8 sp=0x7fff5fbff7a0
/Applications/Arduino.app/Contents/Java/arduino-builder returned 2

Error compiling for board Arduino/Genuino Uno.

Perhaps this is not worth pursuing - I just installed the Arduino IDE on my personal Mac and it all works perfectly. I am going to chalk my problems up to my corporate computer and whatever ways the IT team has decided to lock it down in their ongoing efforts to protect our machines (from us as well as the world).

As you were!