Unable to connect to third party compatible Arduino Uno board

I purchased a starter kit from Amazon, STARTO Starter Kit. This claimed that the board included with the kit was 100% compatible with official version ArduinoIDE. Based on ATMega328 chip for controlling and features faster transfer rates and more memory with ATMega16U2 chip instead of ATMega8U2. I purchased this one because of the price (Ok, I'll admit that I probably purchased this one instead of one with a real Aduino board because I'm a cheap Scot-at least that's what my wife tells me)
It has been nearly 4 months since I purchased it and I am finally getting to the point where I can work with it and try to learn to program in the Arduino language. I am using the web based create site and I have selected the Arduino Uno as the board I am using. Unfortunately, it doesn't appear to be connecting to the board. I have a Dell Uniplex computer running Windows 10 and all of the USB ports are listed as USB 3.0. I have tried two different USB cables and two different USB ports with no luck.
I also purchased the the Arduino for Beginners 2021 Step-by-Step guide to help me get started. But, until I can get the board to connect, I can't get very far.
To be safe, in case it is a problem with the board, I just purchased an Arduino UNO SMD Rev3 [A000073] from Amazon and expect it to be by by the end of the week. But, I would also like to try and get this board working. Have I possibly missed a step in getting it set up and connected? Any ideas or help would be greatly appreciated.


You BYPASSED some important information on the way in !


Can take a few moments to Learn and Use The Forum

It will help you get the very best out of the forum in the future.

  • Your OS and version can be valuable information, please include it along with extra security you are using. Antivirus etc.
  • Always list the version of the IDE you are using and the board version if applicable.
  • Use quote or add error messages as an attachment NOT a picture.
  • How to insert an image into your post. ( Thanks @sterretje )
  • Add your sketch where applicable but please use CODE TAGS
  • Add a SCHEMATIC were needed even if it is hand drawn
  • Add working links to any specific hardware as needed (NOT links to similar items)
  • Remember that the people trying to help cannot see your problem so give as much information as you can


  • Ensure you have FULLY inserted the USB cables.
  • Check you have a COMMON GROUND where required. ( Thanks @Perry)
  • Where possible use USB 2.0 ports or a USB 2.0 POWERED HUB to rule out USB 3.0 issues.
  • Try other computers where possible.
  • Try other USB leads where possible.
  • You may not have the correct driver installed. CH340/341 or CP2102 or FT232 VCP Drivers - FTDI
  • There may be a problem with the board check or remove your wiring first.
  • Remove any items connected to pins 0 and 1.


  • Close any other serial programs before opening the IDE.
  • Ensure you turn off any additional security / antivirus just to test.
  • There may be a problem with the PC try RESTARTING it.
  • You may be selecting the wrong COM port.
  • Avoid cloud/network based installations where possible OR ensure your Network/Cloud software is RUNNING.
  • Clear your browsers CACHE.
  • Close the IDE before using any other serial programs.
  • Preferably install IDE’s as ADMINISTRATOR or your OS equivalent


  • CH340/341 based clones do not report useful information to the “get board info” button.
  • NANO (Old Types) some require you to use the OLD BOOTLOADER option.
  • NANO (ALL Types) See the specific sections lower in the forum.
  • NANO (NEW Types) Install your board CORE’s.
  • Unless using EXTERNAL PROGRAMMERS please leave the IDE selection at default “AVRISP mkII”.
  • Boards using a MICRO usb connector need a cable that is both DATA and CHARGE. Many are CHARGE ONLY.

CREATE editor install locations.

  • On macOs ~/Applications/ArduinoCreateAgent-1.1/ArduinoCreateAgent.app/Contents/MacOS/config.ini
  • On Linux ~/ArduinoCreateAgent-1.1/config.ini
  • On Windows C:\Users[your user]\AppData\Roaming\ArduinoCreateAgent-1.1

Performing the above actions may help resolve your problem without further help.

Language problem ?

Try a language closer to your native language:

Thanks to all those who helped and added to this list.

What does your operating system (which one) think about your board when you connect it?

I read through the "Lean How To Use The Forum" prior to posting my question and thought that I had followed those instructions and explained the issue that I'm having. What information did I bypass? I haven't even started learning about Arduino because I can't get connected to the board.

As to what my computer sees the board as, Device Manager shows the board as an Arduino Uno (Com2)

It is exceptionally unusual to see them as either COM1 or COM2 unless the COM ports were manipulated by hand ?

A picture of the board near the USB connector may be useful about now ?

My computer is running Windows 10 Pro and I changed the Com4 port to Com 2 yesterday while troubleshooting. I have run the offline Sketch program and it connects up just fine, but the online Editor program, while it will allow me to select the Arduino Uno board, will not let me select a Com port. It could be that I'm doing something wrong in the way I have set it up. I also tried to send a photo of the USB port on the board, but I keep getting an error that the entity is too large when I add it as an attachment.

You can resize photos before posting.

You should reset the COM stack if you manually changed the COM port.

Ok, I've got it working now. It turns out that I didn't have the Arduino Create Agent installed. I'm not certain how I missed that step. Thanks for your help.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.