Unable to connect to Uno WIFI AP to set up AP for OTA

I have been working on a project using Uno WiFi Rev2 to do remote sensing of water tank levels connected to mobile via Blynk. Being new to the Arduino platform has been a challenge but I have managed to get to the point where I can readily connect to my home WiFi and upload data to Blynk, and generally all the WiFiNINA example sketched work with no issue. As part of getting this to work I have updated firmware to latest version (1.3.0, confirmed with FirmWareUpdater) and running WiFiNiNA 1.8.0. and Mega AVR 1.87. To date all uploads have been via USB from PC.
I now got to the point where I want to do the outdoor install of Uno project, and my final step was to set up unit as Access Point on my network for over the air (OTA) updating and debugging using the WiFi connection – I hadn’t bothered till now but when I first looked at how to do this it looked easy so put it in the Important but no Urgent folder.

So I finally got round to this, and it hasn’t gone to plan. When I try the OTA set-up procedure as described in link above and set out below, I am unable to connect to the Uno WIFI AP through Wifi as described:
Power the board and wait some time. Search the board in the network list, it has an ESSID like this: Arduino-Uno-WiFi-xxxxxx. Connect your PC/MAC to the Arduino Uno WiFi AP: Open a browser and connect at this address: http://192.168.240.1/
I have spent hours searching for suggestions online, and I done the following based on some online comments:

    1. Checked and updated PC Wifi drivers
    1. Use 12V power input to Uno, and not USB (somebody mentioned 5V USB might be insufficient energy to provide sufficient WIFI single)
    1. Tried different browsers to connect to 192.168.240.1
    1. Tried different PC’s and also different mobile phones.
    1. Loaded a number of different sketches while trying to connect, from Blink (as this was the sample sketch used in description above) to connecting via ConnectWithWPA (usefully connected and IP allocated) and even running AP_SimpleWebServer.
      Independent of what I do none of my devices (PC’s or mobiles) see the Arduino-Uno-WIFi-xxx in the network list, and none of the browsers will connect to WIFI AP via 192.168.240.1, and generally just time out without connecting:
      ERR_CONNECTION_TIMED_OUT
      I have now run out of talent, and hope somebody has some suggestion on what I’m doing wrong?

Regards,
Hugo

the link is for old Uno WiFi, not for Rev2.
OTA for Rev 2 is not available yet afaik

Damn you're right, and I stupidly missed that as I went down the old Uno WiFi rabbit-hole! Very disappointing as I bought this from one of the reputable suppliers listed below, and first three Google search results all still claim Uno Wifi Rev 2 has OTA capability. Makes my project slightly less attractive now :frowning:


Either way, thanks for clarifying.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.