Unable to connect with parallel programmer

Yes, I list this as a bug since I managed to connect to it when I downloaded WinAVR and tried with avrdude.

I'm using ATMega328 and here is a screenshot with proof:

I am willing to work with you guys to resolve this problem, because it is important to be able to program using a parallel programmer (even if most hate them).

I don't know what more to say... Well, the OS is Vista (x86) and I tried to give Arduino admin privileges too without any luck. What more should I try? The path where I put Arduino can that affect this? Should I try installing it to C:/ instead of program files? Please let's find a solution!

Hmm, found the programmers.txt file and tried to change this: parallel.protocol=dapa into this: parallel.protocol=stk200

Now the 1mhz blinking program I had burned with avrdude previously stopped working, so something must have happened. But Arduino still reported errors: I now get this message each time I try. What to try now?

This is the programmer I use btw: http://www.sparkfun.com/commerce/product_info.php?products_id=13

Edit: Seems I got it working! Now there are no reported errors and the led on pin 13 blinks each second (the default test program I guess).

I had to add a delay of 20: parallel.name=Parallel Programmer parallel.protocol=stk200 parallel.force=true parallel.delay=20

Oh, and just a tip to other newbies, do not run Arduino board with programmer plugged in... (only when programming)

Just writing again here to suggest you (Arduino developers) to let the users configure these parameters easier, best would be a popup before burning, and it should also be documented in the help.

i experienced similar situation with yours. maybe this can help. i've tried many many times and come up wtih this. :D

http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1265685755