Unable to download the new libraries

Greetings! Hope you all are doing good.

I have windows 10 Arduino IDE 1.8.13. I'm having problems downloading new libraries. Whenever I open the library downloading menu I get an error:

https://downloads.arduino.cc/libraries/library_index.json

With lot of stuff printed on the console.

I tried doing following things:

  1. Restart my IDE
  2. Restart my computer
  3. Check the link on my browser and I can see the libraries there
  4. Check AppData>local>Arduino15 and I see couple of files named as library_index.json,etc.

I have ESP8266, ESP32 and Minicore links in my preferences >additional board manager URL and have those boards installed.

I can add the zip libraries but can;t download any library from the IDE itself. any help?

Thanks in advance

What exactly do you mean by this ? Do you mean the Library Manager ?

yes the library manager. where I can download the libraries directly from IDE

Hi @Count. I'm going to ask you to post some additional information that might help us to identify the problem.

Please do this:

  1. Close all Arduino IDE windows.
  2. Start the Arduino IDE. (this restart was done to get a blank console pane)
  3. Select Sketch > Include Library > Manage Libraries... from the Arduino IDE's menus.
  4. Try to install a library
  5. After the process fails or hangs, click the Close button.
  6. Click on the black console pane at the bottom of the Arduino IDE window.
  7. Press Ctrl+A.
    This will select all the text.
  8. Press Ctrl+C.
    This will copy the selected text to the clipboard.
  9. Open a forum reply here by clicking the Reply button.
  10. Click the </> icon on the post composer toolbar.
    This will add the forum's code block markup (```) to your reply to make sure the error messages are correctly formatted.
    Code block
  11. Press Ctrl+V.
    This will paste the compilation output into the code block.
  12. Move the cursor outside of the code block markup before you add any additional text to your reply.
  13. Click the Reply button to post the output.

Thank you for detailed explanation.

I have tried using Windows app. I have tried using the installer version of IDE and I also tried using ZIP version and I'm facing the same problem everywhere.

 Error downloading https://downloads.arduino.cc/libraries/library_index.json
java.lang.RuntimeException: java.lang.Exception: Error downloading https://downloads.arduino.cc/libraries/library_index.json
	at cc.arduino.contributions.libraries.ui.LibraryManagerUI.lambda$onUpdatePressed$2(LibraryManagerUI.java:210)
	at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.Exception: Error downloading https://downloads.arduino.cc/libraries/library_index.json
	at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:149)
	at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:130)
	at cc.arduino.contributions.JsonDownloader.download(JsonDownloader.java:49)
	at cc.arduino.contributions.GZippedJsonDownloader.download(GZippedJsonDownloader.java:66)
	at cc.arduino.contributions.libraries.LibraryInstaller.updateIndex(LibraryInstaller.java:84)
	at cc.arduino.contributions.libraries.ui.LibraryManagerUI.lambda$onUpdatePressed$2(LibraryManagerUI.java:203)
	... 1 more
Caused by: java.net.SocketTimeoutException: connect timed out
	at java.net.TwoStacksPlainSocketImpl.socketConnect(Native Method)
	at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
	at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
	at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
	at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)
	at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
	at java.net.Socket.connect(Socket.java:589)
	at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:666)
	at sun.net.NetworkClient.doConnect(NetworkClient.java:175)
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:463)
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:558)
	at sun.net.www.protocol.https.HttpsClient.<init>(HttpsClient.java:264)
	at sun.net.www.protocol.https.HttpsClient.New(HttpsClient.java:367)
	at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewHttpClient(AbstractDelegateHttpsURLConnection.java:191)
	at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.java:1199)
	at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:1050)
	at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:177)
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.connect(HttpsURLConnectionImpl.java:162)
	at cc.arduino.utils.network.HttpConnectionManager.makeConnection(HttpConnectionManager.java:155)
	at cc.arduino.utils.network.HttpConnectionManager.makeConnection(HttpConnectionManager.java:106)
	at cc.arduino.utils.network.FileDownloaderCache.updateCacheInfo(FileDownloaderCache.java:184)
	at cc.arduino.utils.network.FileDownloaderCache.getFileCached(FileDownloaderCache.java:153)
	at cc.arduino.utils.network.FileDownloader.downloadFile(FileDownloader.java:167)
	at cc.arduino.utils.network.FileDownloader.download(FileDownloader.java:129)
	at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:147)
	... 6 more

this is from the ZIP version of IDE. I also noticed that I wasn't greeted with a blank sketch after I closed everything and restarted it. Rather I got to see the same sketch I was working on. Is this a thing to worry?

Also I couldn't download any boards from the boards manager.

Do I need to share anything more details. I'm really stuck can't get a thing working. I'm working on this new code and it requires esp8266 DHT and stuff but I can't get any of it. :frowning:

Hello everyone,
I have the same issue with the "Board manager download".
For example, when I try to download a new board (Intel Curie Boards in this case), I got this:

Error downloading https://downloads.arduino.cc/tools/intel/arc-toolchain-windows-arcem-1.0.1.zip
 CRC doesn't match, file is corrupted. It may be a temporary problem, please retry later.
java.lang.RuntimeException: java.lang.Exception: CRC doesn't match, file is corrupted. It may be a temporary problem, please retry later.
	at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onInstallPressed$2(ContributionManagerUI.java:179)
	at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.Exception: CRC doesn't match, file is corrupted. It may be a temporary problem, please retry later.
	at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:105)
	at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:60)
	at cc.arduino.contributions.packages.ContributionInstaller.install(ContributionInstaller.java:112)
	at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onInstallPressed$2(ContributionManagerUI.java:172)
	... 1 more

Any idea on how to solve?
Thank you in advance

Unfortunately, I don't have any definite ideas about what would cause that. It is possible it was a transient network issue. Does it still occur?

If yes, are you able to open the URL in your browser?

https://downloads.arduino.cc/libraries/library_index.json

I just tried a fresh install of "Intel Curie Boards" on my Windows machine and had no problems, so the file on Arduino's download server is OK.

I remember a previous report of something like this which was caused by a network security system that added some sort of a warning text to downloaded content. Is there anything special about the network you are connecting to the Internet through (e.g., a restricted network at an office)?

Thank you for your answer. Apparently today everything is working fine. Maybe another restart of the pc (or the wifi box) fixed the problem.

I'm glad to hear it is working now. Thanks for taking the time to post an update.

No this is what happens, it is only when you have not been working on a previous or the previous one has been deleted will you get a new sketch.

1 Like

Yes I'm able to access that link thru my browser. But the problem still persist. Do I need to use the installer version rather than zip version of IDE?

I have always been using my computer thru my cellphone hotspot shared. I never had problems earlier, but I'm thinking may be I should try it on some fixed newtwork. Do u think it will have any changes?

what did u do to solve it? I'm still not getting it

when I restart the IDE I'm supposed to be greeted with blank sketch right?

That depends on what you were doing prior to shutting down the IDE.

If the sketch that was open when you closed the IDE has been saved then next time the IDE opens then that sketch will be opened.

If the sketch that was open when you closed the IDE has not been saved then next time the IDE opens then a copy of the BareMinimum sketch will be opened.

Wrong.

I don't think that will have any effect on this problem.

I think it is a good thing to try.

1 Like