Unable to get FT232R drivers loaded under Windows 7 64bit

Hi Guys - its not only Win 7 64 bit but also Win 7 Ultimate 32 bit system that won't install FT232r USB UART drivers; I have tried all combinations of options available on FTDI site a number of times, including latest recommended methods and also older driver versions - nothing works as it should with all resulting in failures and I have simply given up having wasted several long days trying to resolve this issue!! I get the big green ticks for the VCP and Com port drivers during installation but then when you try to update the actual drivers for each board in Device Manager by pointing to the folder where the driver files are supposedly installed they always fail! My adapters include "genuine boards" from Sparkfun and separately from sainsmart (of which the latter I am not sure about how legit this company is as I have experienced a number of different problems in using this company - none of which were satisfactorily resolved by them - in fact the latest problem was simply ignored by them repeatedly asking the same questions despite me supplying all the required details/answers until after about 10 attempts I finally gave up in disgust???) so if the FTDI chip problem relates to use of the alleged fake FTDI chips then some "big companies" have some pretty big explaining to do! Seems like there is something very incidious going on here since so many people are having the same problems???? My only work-around at the moment is to not use this type of board for my XBEE / Uno projects, a real pain in the but and this has just forced me to order several (non-FTDI) boards that I know do work! The other main problem with the FTDI Driver installation is that you are supposed to notate the path where the files are installed but the latest FTDI procedure produces an exe file for the driver installation and you have no way to identify where this finally installs the drivers as it is too quick to observe during running the exe installation file! So if anyone can point me to where the FTDI drivers actually are installed in Win 7 Ultimate 32 bit during driver installation I will be very grateful. I rather suspect this issus is going to get much bigger before it is resolved! Please also note that these drivers are not visible or identifiable in Windows/System32/Drivers folder!! Cheers Ian

If it is genuine FTDI chip, an updateto-date win system (vista/7/8) will be able to download proper driver from contacting Microsoft via the internet and install proper driver. You don't even need admin's password for this auto install. If yours doesn't install, it's probably a fake.

Spark fun got fake ATMEGA chips before and even sold them as practice chips for smd soldering. I think they ultimately discontinued selling them because it is below decent business practice to sell anything fake. I've been burnt by fake chips mostly from arduino nano boards I bought from eBay and another website. What I bought from digikey and mouser work just fine. I also got modules from modern device and spark fun. So far no fakes from them in my hand.

I was having same problems as mentioned. New nano, drivers failed to load in windows. Tried downloading new drivers, same result. Unplugged the nano from the IO shield and everything worked correctly. Supplied stable 6v to power IO shield, everything worked correctly.

old drivers work's for me. don't forget to uninstall new drivers, and never use windows update to avoid upgrade. http://www.f4huy.fr/wp-content/uploads/2015/01/SmartTronik%20CDM%202.04.06.zip

just before, do:

$ sudo apt-get install make gcc libftdi-dev $ wget http://rtr.ca/ft232r/ft232r_prog-1.24.tar.gz $ tar -zxvf ft232r_prog-1.24.tar.gz $ cd ft232r_prog-1.24 $ make $ sudo ./ft232r_prog --old-pid 0x000 --new-pid 0x6001

Hello, I have a duemilanove with the same problems (FTDI fake chip).

I followed the video https://www.youtube.com/watch?v=SPdSKT6KdF8 that was posted in previous pages, and finally achieved in downloading program to the arduino, but it does not work!!!

Should this be another surprise from FTDI?

Has a same situation happened to anybody?

Get a genuine FTDI chip (FT232RL) from reputable vendor (mouser in USA). Find a friend with hot air rework station. Replace chip. Keep fake chip for soldering practice. That's pretty much what I did. And I now own a rework station myself.

The supplier here, where I live, sells only genuine arduino UNO. I cannot find arduino duemilanove for obvious reasons.

My question is can the program written for the Duemilanove run correctly if I download it to Arduino UNO??

Program should work for both. It depends on MCU. Older Duemilanove has 168 and newer 328 same as UNO. If same MCU (ATmega328P) you can upload hex without any change. You can put MCU from Duemilanove to UNO also.

Counterfeit FT232RL should work also. Here on forum there was a discussion about it. Search for it.

evildave_666: All it takes is one slip-up or dishonest staff, anywhere in the supply chain, for counterfeits to sneak into ostensibly reputable products.

FTDI can go stuff themselves, they are even worse than the counterfeiters .... I bought a device with a chip clearly labeled FTDI on it sso I operated in Good Faith yet instead of going after the counterfeiters they just screw over the Consumer completely for something that is obviously no fault of their own?

I won't buy another device that I know has FTDI parts in it anymore because 1) I can't trust it to be genuine and 2) FTDI will punish me and not the counterfeiter if it is not genuine .... and that won't slow down the counterfeiters one bit

F*** FTDI they are no better at all than the counterfeiters .....

liudr: Get a genuine FTDI chip (FT232RL) from reputable vendor (mouser in USA). Find a friend with hot air rework station. Replace chip. Keep fake chip for soldering practice. That's pretty much what I did. And I now own a rework station myself.

FTDI should give me a new chip, they ruined it not me and it was NOT my fault the chip was counterfeit so why am I the only one being punished for these fakes?

I'll just pitch this in the garbage before I buy ANYTHING that has chips labeled FTDI in it or purchase one of their chips for a replacement when I didn't do anything wrong ... PERIOD ... End of story

hi guys !

to all of you who still have problems with conterfeit FTDI chips, please read my previous posts, there is a way to revive them

i highly discourage buying conterfeit stuff.

please, don't PM me, post on the forum for the entire community

have a nice day

It looks like FTDI have made a change of direction. I was conversing with a supplier about a board I bought with a fake chip and they sent me the link to the FTDI drivers and said try these. The drivers - CDM v2.112.04 are dated 3 July 2015, only a week ago, so I gave them a try to see.

And lo and behold, my Windows 8.1 machine now recognised the chip and allocated a COM port. I looked in the Hardware IDs and the PID still shows 0000, so they haven't changed that.

Thinking this was good news I tried to use the board, but no luck. I did a bit of faultfinding and connected the TX and RX lines together and fired up a serial terminal. What I found was what I received wasn't what I was sending. Initially I thought it was some other fault until I realised that what was coming back was NON GENUINE DEVICE FOUND! For every character I sent, the same number of characters of that message was coming back. So if I send a 26 character test message, the full NON GENUINE DEVICE FOUND! comes back!

So the chip is still basically bricked!

The only thing I'm interested to know now is it just because my chip was reprogrammed that it still doesn't work, or will a new, non PID modified chip now work with the new drivers. I only have one of these chips so I'll never know. Maybe someone has a few of them and can try a fresh one.

I have a strong feeling that they will still not work.

I tend to think that not showing a fault with the COM port but still not letting the chip work will be even harder for most people to figure out.

I don't know what's going on with others. Just tried mine again (1.0.6 on Win7Pro), IDE had been open for a couple of days so I get a build folder disappeared error. Restarted the IDE, opened Blink and it downloaded fine again. My Sony Vaio with WinVista that I used for nearly 4 years (and still use occasionally because it has many sketches on it and sometimes I have eagle routing going on in one room while I code in another where the hardware is, but less and less as the keyboard is getting fiddly) still runs file also. I am stumped as to others have such difficulty. I let both computers do Windows updates automatically. Maybe that has something to do with it?

[http://imgupp.com/img/1434586608.jpg

](http://imgupp.com/1434586608.html)

I have both windows 7 64 bit at home and and work. Board with Nano v3. work at home computer and does not work at job, what ever I try to install drivers.... Even more in device manager hardware ID of device show Unknown..... Even more, FTDI programmer won't see it connected.

Anyone can explain this?

To everyone who has been hitting your heads on the wall like I was!!! These Nano boards DO NOT have the FTDI chip!!! They are using a CH340G chip and you need a different driver.

http://www.arduined.eu/ch340g-converter-windows-7-driver-download/

Download this, install it, and remove any driver that you may have already installed as I did. Once you remove the old driver windows may install this driver for you. It did for 1 of 2 of these boards, I had to manually do the 2nd one myself but it works! Probably cause I spent about an hour or so trying to force load the incorrect driver as was explained to me in another forum. I opened Arduino and uploaded a couple programs to be sure. Works Great!!! Hope this helps all who are looking for the FIX!!!

Jeff

These Nano boards DO NOT have the FTDI chip!!!

Then they are not Nanos, they are some clone/derivative that should not be labeled as Nano.

IrOSOz: Initially I thought it was some other fault until I realised that what was coming back was NON GENUINE DEVICE FOUND! For every character I sent, the same number of characters of that message was coming back. So if I send a 26 character test message, the full NON GENUINE DEVICE FOUND! comes back!

I had the exact same problem but managed to repair the chip. Basically you need to go back to an old version of the FTDI driver and disable windows update for drivers. For detailed instructions see this link:

http://electropit.com/index.php/2015/09/06/arduino-nano-v3-0-clones/

Full disclosure: I'm the author of this site.

I suspect we're dealing with counterfeit chips that don't let Windows talk to it. Case in point, I have an XBee FTDI Explorer module and the latest VCP driver that installed on a Sparkfun XBee Explorer part with no issues. However, I also ordered a Saint Smart XBee Eplorer FTDI chip that just won't install all the way. It was a couple of dollars cheaper as I recall. One customer at Amazon had discovered that there are a lot of Chinese 'knock-offs' that just won't install a FTDI VCP newest version with a Windows 8 and Windows 10 OS/device drivers. Apparently he was able to resolve the issue with the Saint Smart part by using an earlier version driver. The newest version is 2.12.2 that worked fine with the Sparkfun XBee Explorer, an authentic chip apparently.

So the solution for me is find a v2.10.1 or earlier or order a Sparkfun part and be done with it. Anyone else have a thought or info they could share? BTW, I haven't a clue where to come up with an earlier version of the driver in question.

My Nano 3.0 (IC Station) has a PID of 6001, not 0000, but will not install. Any ideas on why it won't work? USBVIEW says:

Device Descriptor: bcdUSB: 0x0200 bDeviceClass: 0x00 bDeviceSubClass: 0x00 bDeviceProtocol: 0x00 bMaxPacketSize0: 0x08 (8) idVendor: 0x0403 (Future Technology Devices International Limited) idProduct: 0x6001 bcdDevice: 0x0600 iManufacturer: 0x01 iProduct: 0x02 iSerialNumber: 0x03 bNumConfigurations: 0x01

ConnectionStatus: DeviceConnected Current Config Value: 0x00 Device Bus Speed: Full Device Address: 0x01 Open Pipes: 0

in my case i solved downloading the sw from china where my clone board came ch340 or something like that