Unable to get FT232R drivers loaded under Windows 7 64bit

www.tinyosshop.com I think got burned by that a while ago, and now take pains to get authentic chips. My boards from them work with FTDI driver 2.12.0.0 under Win7 Pro and Win8.1 http://www.tinyosshop.com/index.php?route=product/product&product_id=600

I also have a SainSmart Nano, with the same problem. The solution in the video worked for me, however rather than downloading the drivers from the site mentioned, I just pointed the driver location to the .inf files in the original Arduino IDE installation ,FTDi driver folder.

Indyaner: Just in case people are to lazy to read everything: A potential Fix was just posted in the last post of Page 3! (http://forum.arduino.cc/index.php?topic=270175.msg1909690#msg1909690)

I tried my best in this short video. I hope this will help others. Video Tutorial: https://www.youtube.com/watch?v=SPdSKT6KdF8

I have a couple of panSticks with a similar chip (version 1403-C).

The solution provided by Indyaner worked perfectly for my setup.

Thanks a lot!

Hi Guys,

There is no reason to throw out your old hardware with counterfit FTDI chips. You just need to purchase a standalone programmer. Check out this one https://www.tindie.com/products/Earth_People_Technology/the-visiport2-compact-arduino-programmer/. It uses a legitimate FT232RQ chip, has selectable 5V/3.3V power, and has selectable Arduino reset RTS/DTR.

Hi All, I'm the latest victim of these counterfeit chip =(

I contacted FTDI and they replied this is a counterfeit chip without showing any evidence :P

I'm sharing here how I managed it to work again.

Once you connect the counterfeit chip in Windows 8 or Windows 7 with drivers from windows update or the official driver it will first detect the device and re-write the PID to 0000. After that it will not work at all and it will be detected as an unknown device. You can't change the PID in the .INF files in the official driver, it won't work.

The workaround:

You need a Windows XP system or a Windows XP virtual machine running in a Linux or MAC system. Please note that it won't work in Windows 7 or Windows 8 VMs because it will detect the device as unknown device and it will not allow it to attach it to the virtual machine. I had Mac and it happily allow it to attached to the Windows XP virtual machine. Run your VM or the Windows XP system and attach the USB device to it.

Download the official driver for Windows XP from FTDI site, extract it and edit both the .INF files. Find and replace all 6001 to 0000. Now this modified driver will work with your counterfeit device in Windows XP. Update the drivers from device manager for the counterfeit chip.

To program the PID back to 6001 you need to download M_Prog or FT_Prog utility from FTDI website. Download any one of them and run it. Scan and Parse for the devices. It will show the device attached to your VM or the System. Now change the PID back to 6001 and reprogram it.

Dont connect it to Windows 8 or Windows 7 system now. First delete any existing driver from your system, there is a utility available in FTDI site to remove old drivers. Second find any old FTDI driver from internet, just google it, you will get few links. Disable your internet connection in your system and now connect you device and update the drivers from the downloaded driver. The device will work happily with the old driver.

Still I'm finding a way to disable the eeprom write in counterfeit chip :grin: if someone know please share.

Thank you.

The fix posted at page 3 solves the unrecognized driver problem, but when I upload any sketch, it gives me the error that the COM port isn't accessible?

error message when uploading:

         System wide configuration file is "C:\Program Files (x86)\Arduino/hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : COM3
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
avrdude: ser_open(): can't open device "\\.\COM3": Access is denied.

I too cannot even get windows to recognize the drivers. It says drivers no found, and I am looking right at the ones you are saying should work. I cannot communicate with my nano ver. 3.0 It seems to be running the "blink" program when I plug it in to the USB cord. I tried erasing, and uploading thinking it was just a quirk, but, I cannot get it to communicate with the nano at all.

I am getting really frustrated, and literally P.O'... can someone help before I pull the las few strands of hair I have left on my poor bald head???? ;-)

Thanks....

@RocketDoc57

Did you follow the directions from this video exactly? https://www.youtube.com/watch?v=SPdSKT6KdF8

You may have the official drivers downloaded, but you have to use the "Pick from a list" prompt and point to the driver folder to manually pick the "USB Serial Converter" and then the "USB Serial Port" to have it work.

In my case, it had changed from COM3 to COM4. Once I had the drivers loaded correctly, I could go into the COM4 entry in Device Manager, then go to Port Settings>Advanced and you can change the COM port. I changed COM4 to use COM3, even though it showed it was (In Use) but assigned it anyway. Then I could upload new programs on COM3 like I had been, and when I unplugged the Arduino, the COM port goes away in Device Manager.

I thank you! I did not see the video link, and I followed it and it is working fine!!! My compliments,a nd thanks millions!!!

I've been able resurrect two of my Nano's using Indyaner's workaround video (Thanks!).

On a third Nano however, my system goes to BSOD every time right after I click Yes in the Update Driver Warning box. The blue screen error is PAGE_FAULT_IN_NONPAGED_AREA.

Any suggestions?

Just to add myself to the list of victims. I think FTDI should prevent fake chips from working but altering them is over the limit of just protecting themselves, it's hurting others and their own names. I didn't know some of my stuff have counterfeit chips and how should I? But now they are not going to work thanks to FTDI's little selfish act. I'll switch away from them in my future designs and use other chips. Their chips are neither cheap nor robust. The counterfeits are probably all going on arduino boards. So if we move to other chips, we'll leave FTDI to defend its own little territory like a kid in a play ground. Nobody cares about you FTDI?! I'll go with some reputable dealer that has some TI chips or other companies. Hate their SSOP-only packaging anyway. Bad for prototyping. Thanks for helping me make decision to stay away.

The clone boards with counterfeit chips are probably counterfeit too. I buy MIKROE483 USB/Serial adapters from Mouser, they come with real chips. I buy FTDI derivatives from tinyosshop.com, they got burned in the past with fake chips and are using real ones now. I buy FTDI Basic's from Sparkfun, they use real chips. Folks that buy really cheap ripoff clones from e-bay are likely getting counterfeits. Not robust? I've never had one go bad. I don't think anyone has a DIP version of USB/Serial adapter, so you're stuck with SMD there. I like the MIKROE483; pretty compact, easy to add to a board and stable with connections along 2 sides, vs just 6 pins along one edge. If CP2102 modules like these, that have DTR broken out to a pin, were available with holes vs pins and accepted USB-B Mini or Micro cables, that'd be another option. As is, they are not readily mountable to a PCB. http://www.amazon.com/Generic-CP2102-Module-Serial-Converter/dp/B00EQ1ZDY2/ref=sr_1_2?ie=UTF8&qid=1413670513&sr=8-2&keywords=cp2102

I have just had this problem too.

It was working fine on windows 8.1 for the last month, then all of a sudden. Missing Drivers problem.

I got the drivers from FTDI and re-installed using the .inf files and the .EXE installer. No difference.

I was left with a missing UART Driver.

(This Works for Me, try it at own risk.)

To fix it I got the drivers in normal format with the .INF files. Extracted the zip.

From ControlPanel->Device Manager

Locate the missing UART driver. Right Mouse, Update Driver, Browse Computer -> Let Me Pick->Have Disk->Select the Location of the drivers (port.inf ) and OK.

Now you have a list of drivers to pick from. Choose the USB Serial Converter. OK

After that Another Missing Device Will appear, or Should, if it doesnt then this isnt going to work and uninstall the driver you just picked.

Repeat the above steps and install the USB Serial driver

This should now work. If it doesn't go an uninstall those drivers by right clicking the device and uninstall in driver manager.

MS must have done something to cause this in an update as this was fine a few weeks ago, hope this helps some of you having the same problem.

Thanks for sharing. As you said, it works for you (and some others) but not for everyone. The root cause is FTDI altered the PID of fake FTDI chips. Unless you change it back on an XP system and never use it on a newer system that gets regular updates, the FTDI driver will get installed and screw the chip over again. I bet the FTDI management must have thought the fake chips have helped them enough with increasing market share and now it's time to remove them. It's so easy to do but they waited and waited until now. Good x-mas bonus when a bunch extra orders show up.

Don't think for a moment FTDI is a saint. They could have done it way back but they decided to wait so long. They are just using you, the fake chips and the whole thing like M$ windows taking up market share by means of pirate versions. Now where is M$ windows? Everywhere. Heck I'm typing on one of them.

I bet the FTDI management must have thought the fake chips have helped them enough with increasing market share and now it's time to remove them.

More like cutting into their market share.

Two nanos fully functionally now (used the manual .inf driver assignment as detailed by Indyaner) , thanks guys!

I think most of you guys haven't heard that on Windows 8 or newer, on the 64 bits version, driver signature is required. You cant install a driver that isn't signed by Microsoft. Only on 32bits You get the idea. The move could be made back them, but with the new OS's, is easy for FTDI to combat fake chips.

WHICH Windows update installs this driver?? So we can roll it back... Anyone know??

All,

It is really terrible that FTDI have done this, and then done it silently, if they wanted to do this they should at least put up a message when the device is installed to say it is a fake and that they won't play with the device anymore.

If they wanted to be nice to END USERS they could have put up a message to say you may have unwittingly purchased a device with a fake device present and we will continue. That way end users won't suffer and would probably push back on the original suppliers. Heck, they could even punt you to a site where you could purchase a driver which would work with the bad device so that they could get some money back on it.

Oh, and by the way if you remove the driver and then point it at the driver held in the Arduino IDE it all magically comes back to life.

Well said. After a while we only remember that there was some kind of trouble with FTDI and we should avoid them.