Unable to get WiFi going on a Yun


I just purchased my second Yun board via Amazon, here in Spain, and I cannot seem to solve a configuration problem with it (the first one worked fine).

Here’s what I found out and hopefully, someone can help out:

Both boards are made in Taiwan but designed in Switzerland.

At power up, I was able to see the board with my iPhone and from there sync it with my home router which gave to the board two IP addresses, .178 for Ethernet and .179 for WiFi.

Using Ethernet, I connected to Luci where I found that the Yun had a Dog Hunter image installed in it. Because I’m not familiar with it, I uploaded the Openwrt-Yun image from this site.

Using Luci via IP .178 - Ethernet cable, I browsed around a bit, did a diagnostic ping, updated the time, checked the WiFi connection (65%) saved the changes and logged out.

Here I noticed, under status, that the Yun’s router name was (and still is) Arduino and router model name was Arduino Yun (and still is).

Disconnected the cable and tried to log into Luci again through IP .179 with no avail. However, I noticed that the connection to IP .179 gets established if I leave the Ethernet cable connected (strange).

Using a network scanner on my IPhone, I see the two IPs responding however, IP .178 answer as Linino Dog Hunter LLC and IP .179 as linino Gog Hunter LLC (upper case L). I also noticed that when the Ethernet cable is not connected, IP .179 (WI-FI) does not respond to a ping. It does only if the cable is connected.

Using the USB cable and WiFi Status sketch, I see the same information in the monitor window I see in Luci.

In conclusion, I think that uploading the new image to the board some files, perhaps, didn’t get overwritten (done it via SD card and via browser).

Having said that, is there a linino configuration file I can review from root? Just the fact the Arduino and Linino/linino names appear, make me suspect that there’s a misconfiguration somewhere.