Unable to install plugin

Hey!

I’ve tried to install the plugin about three times now, both overwriting an already installed plugin (which doesn’t work by the way), and uninstalling, deleting and installing the plugin (including downloading it). I get the same error every time (see attached image #1), followed by a confirmation of the plugin having been installed successfully, the tray icon popping up, but still no plugin connection (see image #2)! Any ideas?

Hi flaggermann,
the problem is related with the certificate needed to communicate securely with the Create server. In fact, your username contains a space and the script fails to install the certificates. I'm solving it but there is another strange behaviour: is your username "Batman 1" or "Batman" ? Because the script looks confused on the paths too.

Try opening a terminal and execute

 security add-trusted-cert -d -r trustRoot -k "/Users/Batman\ 1/Library/Keychains/login.keychain" "/Users/Batman/Applications/ArduinoCreateAgent-1.1/ArduinoCreateAgent.app/Contents/MacOS/ca.cart.pem"

and report here if it works, thanks :wink: