unable to install plugins for Mac

My Mac is running on Mac OS Version 10.12.6.
Tried several rounds of installation and uninstallation process, but in vein.
The message displayed: Problem running post-installed setup. Installing may not complete correctly. Error creating service ArduinoCreateAgent.
Any suggestions?
Thanks!!

螢幕快照 2017-10-06 下午6.54.23.png

see http://forum.arduino.cc/index.php?topic=504680.0