Unable to load code onto non Arduino Board


I'm having quiet a bit of trouble trying to get my code onto a non-Arduino board It has been a struggle.
Originally, I received this message:

"Invalid library found in C:\Users-----\Documents\Arduino\libraries\arduino_82576: no headers files (.h) found in C:\Users-----\Documents\Arduino\libraries\arduino_82576"

(Name taken out and replaced with -----)
I searched for people with similar problems and found an answer on this message board saying to just delete the folder if there was nothing in it. Since it was empty, I deleted it. Now I'm receiving this message:

" Using Port : COM3
Using Programmer : arduino
Overriding Baud Rate : 115200
An error occurred while uploading the sketch
avrdude: ser_open(): can't open device "\.\COM3": The system cannot find the file specified.

avrdude done. Thank you."

I'm not quite sure where to go from here because when I try to upload my code to my Arduino UNO board, it uploads without a problem. However, I need to make multiple of these projects and the company I am with doesn't have that huge of a budget. We were hoping these boards work out to save money.

Here is a link to the board I am trying to upload to:

(The boards that have arrived have UNO printed directly underneath the Digital PWM (~) stamp. This is not shown in the photos in the link above)

I hope I have provided enough information....the fact that my Arduino board is totally fine but this new non Arduino board isn't is confusing. I've tried to go to the manufacturers website to see if there were special instructions on how to upload to their board, but I didn't find anything.

Thank you!

You need to select the port of your board from the Arduino IDE's Tools > Port menu.

Sometimes the port will be labeled with the board name in the menu. Other times it will not. If you don’t know which port is your Arduino, you can find it like this:

  • Unplug your Arduino board from the computer.
  • Tools > Port
  • Note the ports, if any, listed in the menu.
  • Close the Tools menu. The ports list is only updated when the Tools menu is re-opened, so this step is essential.
  • Plug your Arduino board into the computer.
  • Tools > Port - The new port listed in the menu is your Arduino board.

My goodness, it worked. I thought I had already tried fixing it that way, but I apparently didn't.
Thank you so much!

Same issue here, Everything worked a few months ago..

I have 1.6, on windows7 with an uno rev3 & a sainsmart uno.

First I had the library issue, did some research and then decided to re-install the entire software so I didn't have duplicate libraries. (figured the included ones would have what I need and can download ones with differing naming conventions to prevent the double library issue. (I have used / added libraries in the past, they are in the "correct" folders & added properly..)

After all that I finally got an example to compile, However now I cannot upload the sketch even though it compiles without errors. My serial port is correct & not going into sleep mode (like some do with propeller devBoard).

Another possible thing is I want to use just a usb cable and never had issues in the past. The programmer setting was on avrisp MKII, which I have for my atmega 16A & 8535, but have never used with uno...Now with research they say to just ignore this setting if using just a usb cable, but Is there a setting under Tools-Programmer for a plain ol' usb cable? I never had any issues in the past when it comes to software & hardware and now there seems to be one after the other. I have always used arduino software for arduino and atmelstudio6 (with avrisp mkII) for the 16A & 8535.

Are any of these reasons putting up red flags for anyone? Is there something about this 1.6 version, or other known factors happening to people? I welcome input/ suggestions/ feedback! Thankyou! :slight_smile:

(rant mode);
I'm not a total noob (recent AAS-elec/robotics grad), but I'm getting pretty frustrated. I just set out to tinker with some easy programming, but hangups like all of this make me want to use my other micros & I'm becoming less & less appreciative of libraries. It was a steeper learning curve but I am more comfortable with the atmega 16A ( & assembly language) where I can not only tell the darn thing what to do, but how to do it
Regards:office 365 document management system