Unable to send a sketch on the control board

Hello guys,

I'm working on the robot Arduino. Last week I uploaded a sketch on the board an today I want to upload a different sketch. When I compile my code, I have no errors. But when I disconect the board from my computer, I see that the robot is doing my previous code, the one I wrote last week. I have no idea why it's no doing my new code and it's still working on my prevous code. When i send a new code, the previous one who should be replaced, is still running.

Can you help me to understand and to solve my problem.

PS : I'm sorry if my english is not good enough, i'm french and if you don't understand something, feel free to ask me.

Sounds like the upload failed and you didn't see the error.

I also think that the upload failed but i have no ideas why.

I was working on this robot since few weeks now and it's the 1st time i have this problem. I thought the problem was due to my computer so i restarted my PC it didn't worked. I also tried to reinstall Arduino 1.6.1, I still have my problem.

If you are seeing no upload error messages you should turn on verbose output. In Arduino Preferences check the box for:

Show verbose output during: compilation upload

If you still don't get any messages, check the box for 'compilation', too.

Hello, i selected "compilation" and i have these errors

avrdude: Version 6.0.1, compiled on Mar 30 2015 at 14:56:06
        Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
        Copyright (c) 2007-2009 Joerg Wunsch

        System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

        Using Port                    : COM10
        Using Programmer              : avr109
        Overriding Baud Rate          : 57600
        AVR Part                      : ATmega32U4
        Chip Erase delay              : 9000 us
        PAGEL                         : PD7
        BS2                           : PA0
        RESET disposition             : dedicated
        RETRY pulse                   : SCK
        serial program mode           : yes
        parallel program mode         : yes
        Timeout                       : 200
        StabDelay                     : 100
        CmdexeDelay                   : 25
        SyncLoops                     : 32
        ByteDelay                     : 0
        PollIndex                     : 3
        PollValue                     : 0x53
        Memory Detail                 :

                                 Block Poll               Page                       Polled
          Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
          ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
          eeprom        65    20     4    0 no       1024    4      0  9000  9000 0x00 0x00
          flash         65     6   128    0 yes     32768  128    256  4500  4500 0x00 0x00
          lfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
          hfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
          efuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
          lock           0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
          calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
          signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

        Programmer Type : butterfly
        Description     : Atmel AppNote AVR109 Boot Loader

Connecting to programmer: .avrdude: butterfly_recv(): programmer is not responding
Problème de téléversement vers la carte. Voir http://www.arduino.cc/en/Guide/Troubleshooting#upload pour suggestions.

I have no idea what it is about !

Hey i pushed the reset button and now i can upload my code. It's working now but i still have no idea why i had that error

Edit : i tried some codes and now i have the same error... So I still need your help guys !

Edit2 : i also tried to send an exemple sketch for the motor board and i'ts works, when i want to work on the control board, i have the error.

Hey guys,

Does someone have a solution for me ? I really need your help i can't work on it since few weeks it's really frustrating.

I tried some solutions available on this page : http://www.arduino.cc/en/Guide/Troubleshooting. But I still haven't fix it.

Does anyone know a solution for me ? While i was looking for a solution, i wrote many codes for different purpose, and now i would like to test my codes.

It's so frustrating when you can't work because of a bug like that ...