Unable to set up Arduino web editor in Windows 10

I want to use the web editor.
I'm using Windows 10 and google chrome.

I'm following the steps in :

which lists these steps:

  • Creating an account (required to use the Web Editor).
  • Download and install the Create Plugin.
  • Make sure our board is recognized by the computer.
  • Upload a simple blink example.

I have created my arduino account.
I am stuck at installing the create plugin.
I have gone to the Create Agent Installation page. and clicked START.
However I see no instructions at this page to complete the installation.
Has the software failed?
I note that I am Administrator on my PC.

Any ideas or suggestions?

After you click start you have to select 32 or 64 bit installer. It's almost certainly 64 bit.
Then it will download the installer.
Open the installer, in your downloads folder, and click yes or ok about 7 or 8 times and you're good to go.

Well, what happens after I click START is very little.
No invitation to select 32 or 64 bit.
In fact no indication of anything I need to do next.
Just a dumb screen which accepts no inputs, with URL:
https://create.arduino.cc/getting-started/plugin/download

  • In other words, a dead-end.

Any ideas anybody?

Here's what I get:

I open this page: Arduino Cloud - Getting started
and see this:

Click "Start", and see this:

Click "WIN64", and see this:

Are you getting anything different from what I have described @gggghhhh ?

Hi in0,

Thank you heaps for the detailed information on what "should" happen. It would be great if it was in the documentation for the Arduino IDE.

So, I do get the first screen you show. And I dutifully clicked the start button in it.

The next screen I get is very like your second screen, but with a crucial difference - the two download buttons are not there. That's what I meant by saying its just a dumb screen which accepts no inputs.

I note that I'm running a fully updated copy of Windows 10 Home Edition, with a very recent version of google chrome (version 95.0.4638.69 which chrome says is up to date), and my user account is an Administrator account.

So, I'm really stuck! I can see that, for you, the software seems to work as advertised. But for me it doesn't.

Dumb question, but is part of the page off the screen where you need to scroll?

Thanks for that suggestion... no suggestion is dumb!

I have just been through the process again to check.

The answer is no. The page I get to, after clicking the start button on the first page you show, has URL Arduino Cloud - Getting started, and won't scroll, and has no scroll bars, either vertical or horizontal.

I know this setup should be totally straightforward - I'm mystified.

Here is the screen I see after clicking "start"...
(I hope it shows - I think you use the upload button to add the screengrab to this post)

Oops, I see the URL didn't appear correctly.
Maybe if I put it in quotes...
"Arduino Cloud - Getting started"

  • Yes, that looks better. (so far)

Oh, no it doesn't!
When I hit "reply" the URL gets changed, and doesn't appear in the post, it gets replaced by the page title or something.
Oh well. It's a wee bit too smart.

But if you mouse-over the transformed text, you get shown the URL at the bottom of the screen, in chrome anyway.

Sorry about all this messing around. I'm very new to this forum, and don't really know how things work yet.

No worries.

If you don't want the forum software to work its magic on your link text, wrap it in angle brackets.

This markup:

has URL <https://create.arduino.cc/getting-started/plugin/download>, and won't scroll

renders like this:
has URL https://create.arduino.cc/getting-started/plugin/download, and won't scroll

The "onebox" link preview thing is occasionally cool, but I have never found value in the inline link text replacement the Discourse forum software does. I find myself doing the angle bracket wrapping trick more often than not nowdays.

Thanks in0.
I guessed wrong - I tried quotes, not angle brackets!
Is there a guide to using the forum software? The FAQ has no details.

The most important thing to know is that the forum software supports the Markdown markup language for formatting your posts. There are a lot of excellent references for Markdown, but this seems like a decent one:

Markdown is actually a partial superset of HTML, meaning that, in addition to the primary Markdown markup syntax, you also have access to the fundamental HTML syntax. Usually not necessary, but every so often there is something missing from Markup that I fall back on HTML for. For example, the Discourse software has an annoying handling of the IDs of the automatically generated anchors for Markdown headings, so I use HTML <a> tags to supplement my Markup with custom anchors.

To make matters more confusing, the forum software also recognizes some flavor of the BBCode markup language. I don't bother with that much because Markdown is much more generally useful (BBCode is mostly only used on forums, but Markdown is used everywhere), but there are one or two things BBCode does that Markdown and HTML can't. The notable one is the quotes. This is how a Markdown quote looks:

> Is there a guide to using the forum software?

renders as:

Is there a guide to using the forum software?

That's OK, but BBCode supports the additional metadata on the quote that identifies its source:

[quote="gggghhhh, post:14, topic:921586"]
Is there a guide to using the forum software?
[/quote]

renders as:

Then there are some other additional markup capabilities such as emoji that are not part of any of those languages.

Thanks in0, that's very helpful.
Now at least I know where to look for formatting info.
I've never paid a lot of attention to markup languages - maybe now I actually need to...
It's a bit disconcerting when you format your post nicely in the box, but when you hit "reply" it changes, even if you don't use any markup tags! But OK, that's how it is.

The little toolbar in the post composer provides a decent amount of formatting capabilities without any need to learn a language.

But Markdown is quite a useful skill to have since it is used in many places (e.g., GitHub, Stack Exchange). I also find Markdown to be quite intuitive. I used the BBCode daily for many years, but still don't know most of it by heart, but I had no problem becoming proficient in Markdown.

Here is the URL the "DOWNLOAD FOR WIN64" button points to:

https://downloads.arduino.cc/CreateAgent/Stable/ArduinoCreateAgent-1.2.4-windows-amd64-installer-chrome.exe

Try opening that link to download and then running the downloaded "ArduinoCreateAgent-1.2.4-windows-amd64-installer-chrome.exe" file to install Arduino Create Agent.

Once Arduino Create Agent is installed and running, you can jump straight to using Arduino Web Editor. No additional setup is needed.