Unable to update NINA Firmware

When I create a thing and try to upload a sketch I get a pop up telling me that the NINA firmware needs to be updated. I have tried several times to follow the subsequent instructions but the update fails every time. I even tried their suggestions of restarting arduino create and reconnecting the microcontroller. How can I solve this problem?

Hi @arvindrk. I'm sorry to hear the firmware update is not working for you.

Are you getting any error or warning messages when that happens? If so, please post the full and exact text of them.

To answer your question, I never got any warnings or errors, just a dialog box telling me to try again and 2 suggestions (restart arduino create and reconnect nano). But I was actually able to sort it out when I attempted to update the firmware through the IDE and restarted my system. Despite updating on the IDE, it still said that the NINA firmware needs to be updated when I uploaded my sketch through the IOT cloud. But this time it was successful!!
HOWEVER, after the update I am unable to configure my device anymore. It gets stuck on "step 3: Configuring secure element" for about 5-7 min and then tells me to try again. Any idea what is causing that?

@arvindrk has created a dedicated topic for the discussion of the problem with configuring secure element: