unable to upload any programs to the arduino

I just got my brand new arduino mega 2560 in the mail. i was never able to upload any programs to it at all. i have tried quite a number of different programs and they all result in the following errors: avrdude: stk500v2_ReciveMessage(): timeout and avrdude: stk500v2_getsync{): timeout communicating with programmer

If anybody else has had this problem and was able to fix it, please let me know how you did it. I need to get this fixed ASAP as this microcontroller will be used in a project for one of my classes that has a due date which happens to be closing in uncomfortably fast. Thank you in advanced to anyone who can help me get this problem resolved.

Did you read the troubleshooting guide?

http://www.arduino.cc/en/Guide/Troubleshooting#upload

Have you selected the Mega2560 board in the IDE?

Yes, I do have the ide set for the mega 2560, and nothing in the troubleshooting documentation has worked, got any other ideas?

Are any wires plugged into it apart from the USB cable?

Can you enable "verbose" uploading (see File -> Preferences) and then post what appears.

What operating system are you using?