Unable to upload -- >ERROR: Timed out waiting for Arduino 101.

OS: Windows 10, Able to see Arduino 101 in device manager with COM3 Port when I connect Arduino101.

However unable to upload the code to board. I am getting this error : Unable to find device When I checked in the web, similar problems posted here http://arduino.stackexchange.com/questions/18959/error-timed-out-waiting-for-arduino-101-anything-i-can-do and here

I used Galileo before Curie.. Do I need uninstall Galileo board (remove) before adding ARduino101.

Please help to upload the code.

Hi sivaiots14,

have you tried using this approach? http://forum.arduino.cc/index.php?topic=368654.msg2542777#msg2542777

The issue should be solved with the next Curie core update. Galileo core can coexist with 101 without any problem.

Please report here any result!

Thanks for the reply. Yes, I had done that change of script clupload_win.sh Still I am facing the issue with upload.

Also when you say, it will be fixed in next release.. should I rebuild from "Curie" from board manager or are you suggesting to pull the more recent Nightly build of Arduino IDE?

You need to wait for a new Curie core update (you will be notified by the IDE when it is available), updating the IDE will have no effect. As a last test, try reinstalling the drivers manually executing as administrator dpinst-x86.exe or dpinst-amd64.exe (depending on your Windows installation - 32 or 64 bits). You can find that files inside "C://Users/yourusername/Appdata/Local/Arduino15/packages/Intel/tools/sketchUploader/1.6.4+1.14/drivers/"

I quickly ran the drivers from the path you specified. However I am getting the same error. Any tentative date for next core release? Appreciate your instant response and great support.

Sometimes the board doesn't reset when the IDE commands it to. If that happens, just press teh reset button on the 101 board. It will stay in DFU for several seconds and give Windows a chance to download it.

On my Windows machine, I re-ran the driver installation and pressed the reset button on the board to make sure it could see the drivers load in device manager for both DFU and cdc-acm virtual serial.

Thanks @Nuketopia for response. Can you explain what is reset and what is master reset? How to verify both DFU and cdc-acm virtual serial is loaded? All I can see is "COM3" in device manager with Arduino101 name. Few click sounds is the identifiable note from OS. Please guide me.

The MASTER RESET is intended to reset both the cores of Curie chip, while RESET will only reset the sketch (though the software doesn't support that yet, so they both reset the whole board). When pressing MASTER RESET the board will enter DFU and you should see an entry in your device manager similar to this one

Let me check this and post my screenshot

These are the devices you should see in Windows Device Manager (see screenshots) if the board is connected and the drivers are loaded correctly. The DFU device is only present for a few seconds after a board reset - then the Arduino101 COM device appears.

  • libusb (WinUSB) devices / Arduino 101 DFU Interface
  • Ports (COM & LPT) / Arduino 101 Serial Monitor (COMx)



Attaching the screenshot and Verbose text.

I tried and reproduced the issue in Ubuntu 14.04, error remains same.

Does it mean, I corrupted the board somehow…
Do I need to buy new one?

Verbose text

"-larc32drv_arduino101" -Wl,--no-whole-archive -Wl,--start-group "-larc32drv_arduino101" -lc -lm -lgcc "C:\Users\siva\AppData\Local\Temp\build0aa667220df52b84a1b6f11f30f59118.tmp\sketch\Blink.ino.cpp.o" "C:\Users\siva\AppData\Local\Temp\build0aa667220df52b84a1b6f11f30f59118.tmp\core\variant.cpp.o" "C:\Users\siva\AppData\Local\Temp\build0aa667220df52b84a1b6f11f30f59118.tmp/core\core.a"
"C:\Users\siva\AppData\Local\Arduino15\packages\Intel\tools\arc-elf32\1.6.4+1.0/bin/arc-elf32-objcopy" -S -O binary -R .note -R .comment -R COMMON -R .eh_frame  "C:\Users\siva\AppData\Local\Temp\build0aa667220df52b84a1b6f11f30f59118.tmp/Blink.ino.elf" "C:\Users\siva\AppData\Local\Temp\build0aa667220df52b84a1b6f11f30f59118.tmp/Blink.ino.bin"
"C:\Users\siva\AppData\Local\Arduino15\packages\Intel\tools\arc-elf32\1.6.4+1.0/bin/arc-elf32-strip" "C:\Users\siva\AppData\Local\Temp\build0aa667220df52b84a1b6f11f30f59118.tmp/Blink.ino.elf"
"C:\Users\siva\AppData\Local\Arduino15\packages\Intel\tools\arc-elf32\1.6.4+1.0/bin/arc-elf32-objcopy" -S -O ihex -R .note -R .comment -R COMMON -R .eh_frame  "C:\Users\siva\AppData\Local\Temp\build0aa667220df52b84a1b6f11f30f59118.tmp/Blink.ino.elf" "C:\Users\siva\AppData\Local\Temp\build0aa667220df52b84a1b6f11f30f59118.tmp/Blink.ino.hex"

Sketch uses 29,989 bytes (15%) of program storage space. Maximum is 196,608 bytes.
Forcing reset using 1200bps open/close on port COM3
C:\Users\siva\AppData\Local\Arduino15\packages\Intel\tools\sketchUploader\1.6.4+1.14/x86/bin/bash.exe --noprofile C:\Users\siva\AppData\Local\Arduino15\packages\Intel\tools\sketchUploader\1.6.4+1.14/clupload/cluploadArduino101_win.sh C:\Users\siva\AppData\Local\Arduino15\packages\Intel\tools\sketchUploader\1.6.4+1.14/x86/bin C:\Users\siva\AppData\Local\Temp\build0aa667220df52b84a1b6f11f30f59118.tmp/Blink.ino.elf COM3 verbose 
Starting download script...
Args to shell: C:\Users\siva\AppData\Local\Arduino15\packages\Intel\tools\sketchUploader\1.6.4+1.14/x86/bin C:\Users\siva\AppData\Local\Temp\build0aa667220df52b84a1b6f11f30f59118.tmp/Blink.ino.elf COM3 verbose
Serial Port: COM3
BIN FILE C:/Users/siva/AppData/Local/Temp/build0aa667220df52b84a1b6f11f30f59118.tmp/Blink.ino.bin
Waiting for device...
Cannot open DFU device 8087:0aba
Cannot open DFU device 8087:0aba
Cannot open DFU device 8087:0aba
Cannot open DFU device 8087:0aba
Cannot open DFU device 8087:0aba
Cannot open DFU device 8087:0aba
Cannot open DFU device 8087:0aba
Cannot open DFU device 8087:0aba
ERROR: Timed out waiting for Arduino 101 on COM3

Thanks the quick responses on the forum.

I could resolve the problem by pressing "master reset" and manually upload(Download to Device) using the script.

Since manually I have to press reset button, I introduced 3 second sleep and then ran the DFU-UTIL command to download the bin file.

Attaching command prompt output

C:\Users\siva\AppData\Local\Arduino15\packages\Intel\tools\sketchUploader\1.6.4+1.14\x86\bin>sleep 3

C:\Users\siva\AppData\Local\Arduino15\packages\Intel\tools\sketchUploader\1.6.4+1.14\x86\bin>dfu-util -D C:\Users\siva\AppData\Local\Temp\build0aa667220df52b84a1b6f11f30f59118.tmp\Blink.ino.bin -v --alt 7 -R
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Opening DFU capable USB device...
ID 8087:0aba
Run-time device DFU version 0011
Claiming USB DFU Interface...
Setting Alternate Setting #7 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 0011
Device returned transfer size 2048
Copying data from PC to DFU device
Download        [=========================] 100%        17188 bytes
Download done.
Sent a total of 17188 bytes
state(2) = dfuIDLE, status(0) = No error condition is present
can't detach
Resetting USB to switch back to runtime mode

I have Windows8.1 and I do not see a C;\Users\my user name\AppData\Local\ Arduino15...etc. in my installation. Am I missing something is my installation 6.1.7.


I had also this problem. I solved it so: Klick on the "Upload" button in IDE, wait 3-5 seconds and press and hold the button "Master Reset" on your Arduino 101. After that my Arduino worked fine.

I had the same issue with a 101 I brought of the shelf from Fry's in April 2017. On a whim, I downgraded the board version from 2.02 to 1.07 and it worked.

I am using Windows 10 and am using the Arduino Editor on the Web and have installed the Windows Driver , but getting the time out message. Have tried with 2 lap tops and same issue. Getting frustrated... How do I downgrade it?


I think you mean UPGRADE it.

There was an update for the 101that you should probably install.

Another thing is to AVOID USB 3.0 ports where possible with Arduino products unless you are 100% sure about the compatibility.

The desktop version of the IDE is your only proper method for the firmware upgrade and after that it should be fine with the web editor.

The process is explained HERE

Was having the same problem and this post solved it for me with a 3 second wait.

"I solved it so: Click on the "Upload" button in IDE, wait 3-5 seconds and press and hold the button "Master Reset" on your Arduino 101. After that my Arduino worked fine."

Thanks Mates!