Unable to upload: port has disappeared after working for a month

I started using my DFRduino Uno about a month ago with my 2010 MacBook running Arduino 1.6.6 on El Capitan. I couldn't see the port until I disabled OS X SIP in terminal but that solved it.

This worked fine until this afternoon when halfway through doing some work with motors, the code failed to upload. The error message read can't open device "/dev/cu.usbmodem411": No such file or directory

I have reinstalled the drivers and run through everything at https://www.arduino.cc/en/Guide/Troubleshooting but nothing seems to do it.

I now get the following error message counting through 1 to 10 of 10: avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

I can't quite work out what's happened, or why it stopped working all of a sudden? Any help would be much appreciated as I have a hand in coming up in the next week!

Thanks in advance for any help!

Also, the green LED by pin 13 is on, as is the red ON LED, so there is power.

However, I cannot see the port in system information.