Unable to upload sketch. Solved

I have recently made two changes to my system. Changed from crunch bang linux to Debian Jesse and downloaded and installed the latest Arduino ide. (1.6.5, previously using 1.0.4) When i try and upload a sketch I get the following error message.

avrdude: ser_open(): can't open device "COM1": No such file or directory
ioctl("TIOCMGET"): Inappropriate ioctl for device

Board selected is Arduino/genuine uno

Serial port shown is /dev/tty/asm0 (none other shown)

dmesg|tail
[37202.054517] usb 1-4.2.2: SerialNumber: 6493534333335161F110
[37202.055271] cdc_acm 1-4.2.2:1.0: ttyACM0: USB ACM device
[38429.261339] usb 1-4.2.2: USB disconnect, device number 11
[38437.308158] usb 4-1: new full-speed USB device number 3 using uhci_hcd
[38437.506844] usb 4-1: New USB device found, idVendor=2341, idProduct=0001
[38437.506854] usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=220
[38437.506861] usb 4-1: Product: Arduino Uno
[38437.506868] usb 4-1: Manufacturer: Arduino (www.arduino.cc)
[38437.506874] usb 4-1: SerialNumber: 6493534333335161F110
[38437.510077] cdc_acm 4-1:1.0: ttyACM0: USB ACM device

Loopback test gives board at com1 not available

I have tried uploading the sketch with root permissions.
I have tried uploading the sketch from codebender
I have tried with no usb hub
I have tried repowering/reseting, pluging in the usb cable before and after opening the ide.
After the initial error I have been using the blink sketch for trouble shooting.
All give the error pasted above.

I have had a good trawl through the forum using the search bar with the error message but have not been able to come up with any relevant help. If anyone is able to point me in the right direction it would be appreciated.

I have just reinstalled Arduino ide 1.0.4. With this older version the serial port selection dialogue is greyed out. I hope this additional information narrows down the possible causes of the error. Thanks

Duh, just needed to add myself to dialout group and it all works again.