Unable to upload sketch to Adrinuo Nano

I tried to upload my sketch to Nano, it came up with a error message "overriding baud rate 115200"
Please advise how to solve this problem.

Thx

Select Tools > Processor > ATmega328P (Old Bootloader) and then try uploading again.

Thank you very much. Let me try again and see if I can fix the problem.

I had tried to change the processor to (Old Bootloader) but it still did not work. Another error message was shown (overriding baud rate :57600). Do I also need to choose a correct program for Nano and the one that I used was Adrunio ISP.

SIMONTONG:
Another error message was shown (overriding baud rate :57600).

The “Overriding Baud Rate” thing is in no way an error message. It’s just some information about the upload parameters that’s provided by the avrdude program used to upload to your Nano. You will find that error messages almost always have the word “error” in them.

SIMONTONG:
Do I also need to choose a correct program for Nano and the one that I used was Adrunio ISP.

No. The sketch you’re trying to upload has absolutely nothing to do with the upload failure.

Please do this:

  • (In the Arduino IDE) File > Preferences
  • Uncheck the checkbox next to “Show verbose output during: compilation”
  • Check the checkbox next to "Show verbose output during: upload
  • Click “OK”
  • Sketch > Upload
  • After the upload fails, you’ll see a button on the right side of the orange bar “Copy error messages” (or the icon that looks like two pieces of paper at the top right corner of the black console window in the Arduino Web Editor). Click that button.
  • In a forum reply here, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum’s code tags markup to your reply.
  • Press “Ctrl + V”. This will paste the upload output between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.

Arduino: 1.8.9 (Windows 10), Board: "Arduino Nano, ATmega328P (Old Bootloader)"

Sketch uses 930 bytes (3%) of program storage space. Maximum is 30720 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM10 -b57600 -D -Uflash:w:C:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_910468/EXAMPLE_02.ino.hex:i
An error occurred while uploading the sketch

avrdude: Version 6.3-20171130
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM10
Using Programmer : arduino
Overriding Baud Rate : 57600

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Is it a genuine Arduino Nano or a clone?
Clones quite often use a CH340 chip for USB to serial.
It's possibly why Pert suggested changing to old bootloader.
The CH340 chip (on the underside of clones) will work with the old bootloader but not the default.
Did you change the programmer to Arduino as ISP?

tigger:
The CH340 chip (on the underside of clones) will work with the old bootloader but not the default.

Tools > Processor > ATmega328P (Old bootloader) is only indirectly related to CH340. The CH340 will work perfectly fine with the new bootloader. However, you will usually find that you need to select Tools > Processor > ATmega328P (Old bootloader) when you have a clone or derivative board simply because the manufacturers are still putting the old bootloader on them. There would be absolutely no problem if the manufacturers switched to using the new bootloader or if the owner of the clone/derivative board burned the new bootloader to their board.

tigger:
Did you change the programmer to Arduino as ISP?

The Tools > Programmer menu selection is only used when you do a Sketch > Upload Using Programmer or a Tools > Burn Bootloader. When you are doing a standard upload (as SIMONTONG is doing), it makes absolutely no difference what you have selected from the Tools > Programmer menu.

@SIMONTONG's problem is very tricky because avrdude is silently failing at the very start of the upload. This is very rare. Usually when there is an upload problem the verbose output gives us some nice information on the cause of the failure but in this case there is no information at all to work with!

Purely a wild guess: This sort of error could be caused by your antivirus software. Try TEMPORARILY disabling your antivirus for a single upload to see if the problem goes away, then turn the antivirus back on. If the problem doesn't occur with the antivirus off you will need to adjust the settings of your antivirus to whitelist the appropriate file, folder, or process so it doesn't interfere with uploading.

I enabled verbose output for both Arduino IDE and Platformio to get the exact avrdude command executed to upload the compiled hex-file. I then adopted the call to avrdude from the Arduino IDE with the path of the compiled hex-file Myloweslife.

I have disabled the anti-virus program and change the programmer to Adrunio as ISP but it still can upload the sketch to the Nano. Arduino: 1.8.9 (Windows 10), Board: "Arduino Nano, ATmega328P (Old Bootloader)"

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\SIMON TONG\Documents\Arduino\libraries -fqbn=arduino:avr:nano:cpu=atmega328old -vid-pid=0000_0000 -ide-version=10809 -build-path C:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_974118 -warnings=none -build-cache C:\Users\SIMONT~1\AppData\Local\Temp\arduino_cache_671325 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc-5.4.0-atmel3.6.1-arduino2.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude-6.3.0-arduino14.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA-1.2.1.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\SIMON TONG\Documents\Arduino\EXAMPLE_02\EXAMPLE_02.ino
C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\SIMON TONG\Documents\Arduino\libraries -fqbn=arduino:avr:nano:cpu=atmega328old -vid-pid=0000_0000 -ide-version=10809 -build-path C:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_974118 -warnings=none -build-cache C:\Users\SIMONT~1\AppData\Local\Temp\arduino_cache_671325 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc-5.4.0-atmel3.6.1-arduino2.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude-6.3.0-arduino14.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA-1.2.1.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\SIMON TONG\Documents\Arduino\EXAMPLE_02\EXAMPLE_02.ino
Using board 'nano' from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr
Using core 'arduino' from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr
Detecting libraries used...
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10809 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\eightanaloginputs" "C:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_974118\sketch\EXAMPLE_02.ino.cpp" -o nul
Generating function prototypes...
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10809 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\eightanaloginputs" "C:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_974118\sketch\EXAMPLE_02.ino.cpp" -o "C:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_974118\preproc\ctags_target_for_gcc_minus_e.cpp"
"C:\Program Files (x86)\Arduino\tools-builder\ctags\5.8-arduino11/ctags" -u --language-force=c++ -f - --c++-kinds=svpf --fields=KSTtzns --line-directives "C:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_974118\preproc\ctags_target_for_gcc_minus_e.cpp"
Compiling sketch...
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -MMD -flto -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10809 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\eightanaloginputs" "C:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_974118\sketch\EXAMPLE_02.ino.cpp" -o "C:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_974118\sketch\EXAMPLE_02.ino.cpp.o"
Compiling libraries...
Compiling core...
Using precompiled core: C:\Users\SIMONT~1\AppData\Local\Temp\arduino_cache_671325\core\core_arduino_avr_nano_cpu_atmega328old_0c812875ac70eb4a9b385d8fb077f54c.a
Linking everything together...
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc" -w -Os -g -flto -fuse-linker-plugin -Wl,--gc-sections -mmcu=atmega328p -o "C:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_974118/EXAMPLE_02.ino.elf" "C:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_974118\sketch\EXAMPLE_02.ino.cpp.o" "C:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_974118/..\arduino_cache_671325\core\core_arduino_avr_nano_cpu_atmega328old_0c812875ac70eb4a9b385d8fb077f54c.a" "-LC:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_974118" -lm
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-objcopy" -O ihex -j .eeprom --set-section-flags=.eeprom=alloc,load --no-change-warnings --change-section-lma .eeprom=0 "C:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_974118/EXAMPLE_02.ino.elf" "C:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_974118/EXAMPLE_02.ino.eep"
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-objcopy" -O ihex -R .eeprom "C:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_974118/EXAMPLE_02.ino.elf" "C:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_974118/EXAMPLE_02.ino.hex"
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-size" -A "C:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_974118/EXAMPLE_02.ino.elf"
Sketch uses 930 bytes (3%) of program storage space. Maximum is 30720 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM10 -b57600 -D -Uflash:w:C:\Users\SIMONT~1\AppData\Local\Temp\arduino_build_974118/EXAMPLE_02.ino.hex:i
An error occurred while uploading the sketch

avrdude: Version 6.3-20171130
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM10
Using Programmer : arduino
Overriding Baud Rate : 57600

@SIMONTONG did you ever try temporarily disabling your antivirus software for a single upload as I suggested you do a few days ago?:

pert:
Purely a wild guess: This sort of error could be caused by your antivirus software. Try TEMPORARILY disabling your antivirus for a single upload to see if the problem goes away, then turn the antivirus back on. If the problem doesn't occur with the antivirus off you will need to adjust the settings of your antivirus to whitelist the appropriate file, folder, or process so it doesn't interfere with uploading.

I disabled the anti-virus yesterday but still cannot upload the sketch to Nano. Is there anything I need to change the com port setting.