Unable to Upload Sketches to Arduino on Breadboard ATMega328P-PU Using a FT232R

Problem: I am unable to upload sketches to my Arduino on a breadboard when using my FT232 Module. I get the following error; “avrdude: stk500_getsync(): not in sync: resp=0x00” at the bottom of the Arduino window.

I believe that I have some sort of driver, COM port issue, or a simple wiring issue because I got the same error with my CP2102 module that I previous purchased. You may view that forum here: Unable to Upload Sketches to Arduino on Breadboard ATMega328P-PU Using a CP2102 - Programming Questions - Arduino Forum

Details:

  • FT232 Module Purchased - http://amzn.com/B00GD6GE6O

  • ATMega328P-PU – I am sure that this chip works. I bootloaded 4 chips and then successfully uploaded the “Blink” example sketch using the Arduino as ISP. I swapped out other ATMega328P-PU chips to make sure that it was not a corrupt bootloader.

  • Wiring
    Breaduino FT232
    VCC ==> VCC
    GND ==> GND
    GND ==> CTS
    TX ==> RXI
    RX ==> TXO
    RST ==> Capacitor to DTR

  • Arduino IDE – I have tried both the older and newer versions of Arduino IDE to upload sketches.

  • FTDI Drivers – I have tried updating and rolling back the FTDI driver versions on my computer. It’s very possible that this is still an issue though.

  • Baud Rate – I have tried different baud rates via the device manager on my PC.

  • Set RTS on Close – I have tried enabling and disabling this option via the device manager on my PC.

  • Reset Button – I have tried holding the reset button until the “uploading sketch” text comes up in the Arduino software. This did not work.

  • TX vs. RX Wiring – I have also tried swapping the wires so it is TX==>TX and RX==>RX vs. the above wiring. This did not work either.

  • TX and RX Lights – It appears as though there are TX and RX lights on the FT232. The RX light blinks when I try uploading a sketch but the TX light does not light up at all.

  • TX and RX Connection – I tested this connection via the serial monitor and everything was repeated back to me.

  • 3.3v vs. 5v – I have confirmed that the Arduino on the breadboard is getting power (red LED on breadboard). Using a different voltage has not worked either.

  • Programmer – I have tried using the regular Arduino programmer. I have also tried holding down the shift key and uploading sketches via the AVR ISP and the AVR ISP mkII programmer options.

Please tell me what I’m doing wrong! I would really like to use my FT232 module to upload sketches to my Breaduino vs. using my Arduino Uno to upload sketches! Thank you!

Update: I am able to upload sketches to my Arduino Uno from both the new FT232 module I purchased and my CP2102 module that I previously thought was defective.

However, I am still not able to upload sketches to my Arduino on Breadboard via either module.

Please see the screenshot below to review my wiring.

PLEASE HELP ME! I am so frustrated and I can’t figure out what I’m doing wrong!

Verbose Output:

[/avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino 1.5.6-r2/hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : COM5
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Recv: 
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done.  Thank you.
code]

Chip is not responding. It definitely has a bootloader installed, and you are selecting the matching board type? Could try other board types - Uno, Duemilanove.

Are 22pF cap leads touching the oscillator case? Looks like they might be - separate them.
Try swapping the Rx/Tx wires.
Try adding 0.1uF cap on VCC, AVCC pins to Gnd.
Do not connect Aref to +5 - 0.1F cap to Gnd only.

  • Checked the oscillator case and also moved the crystal. Does it matter if another wire (not a bare wire) is touching one or both of the crystal’s legs?
  • Swapped the RX/TX lines, but it did not work.
  • Added a .1 uf cap on VCC pin to GND.
  • Added a .1 uf cap on AVCC pin to GND.
  • Connected AREF to GND via a .1 uf cap.
  • Tried using a different board (the Duemilanove)

Still the same error!

Again, I can upload sketches to the Uno via the FT232 module vs. the standard USB cable. I can also upload sketches to my Breaduino via Arduino as ISP.

Whenever I click the upload the FT232 module’s RX light blinks 3 times, but the TX light does not come on. However, if upload a sketch to my Uno, both of the RX and TX lights will light up like they should. This is really not making sense to me.

Updated pic of my Breaduino below:

Got me stumped at this point.

CrossRoads, would you suggest posting this problem in some other forum?


What exactly tells the FT232 module to transmit data? Is it possible to "trick" the module into sending the data? Is there something I can test with my multimeter to troubleshoot the problem more? It seems as though the data transmission or CTS is the main issue.

Again, I was able to upload sketches to my Uno via the FT232 module by following the directions posted here:
http://forum.arduino.cc/index.php/topic,102600.0.html. I moved my FT232 module over to a clear section of my breadboard and wired everything per the directions in the forum (I was NOT able use the same wiring in the screenshots below).

I also recently tried my other breadboard and a different USB cable; same result - error.


Capacitors - Does it matter what size or type of capacitors I use? I ask because I've seen "decoupling capacitors" mentioned in forums with similar issues as mine.

[SOLVED!]

I was able to get both my FT232R and my CP2102 modules to work! The problem came down to the capacitor I was using and how I had it connected to my Breaduino.

I still currently have to perform a manual reset in order to upload sketches, but at least I am able to upload sketches.

Yeeaaa.
It looks ok in your pictures. What do you think is wrong with it?