Unable to upload to Sparkfun RedBot Mainboard

Hi

I am just trying to upload (from a mac) a basic blink test to the Sparkfun RedBot but I keep getting this error:

Binary sketch size: 1,076 bytes (of a 32,256 byte maximum)
/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -carduino -P/dev/tty.usbserial-A6026LQW -b115200 -D -Uflash:w:/var/folders/jt/mpqf6pmx6kd8k1q7cvlmnwnw0000gn/T/build1177920591307596948.tmp/sketch_dec27a.cpp.hex:i

avrdude: Version 5.11, compiled on Sep  2 2011 at 18:52:52
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/Users/bob/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/tty.usbserial-A6026LQW
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

avrdude done.  Thank you.

The board has power and I have tried it with nothing plugged in but it won't upload (except battery and usb). I have tried looking around on the internet but no solutions have worked for me.

Any help would be greatly appreciated; Orange_Cyborg

Can you see what driver is loaded for the board when it is plugged in? Do you have drivers for it?

Thanks for the reply, the board is basically a modified Uno but I tried my actual Uno and it works fine, but this board brings up errors. This is the actual board: https://www.sparkfun.com/products/12097 .

The guides for the RedBot all say you just plug it in and it works as an Uno, so I guess I have the drivers for it.

Hope this answers your questions Orange_Cyborg

The Uno R3 uses a different USB to serial converter. You need the FTDI drivers for the USB to serial converter available from FTDI's website.

I updated the VCP driver for the FTDI chip on the board(FT232R) and this fixed my problem: http://www.ftdichip.com/Products/ICs/FT232R.htm

I had previously updated the D2XX but did't see the VCP, my error.

Thanks for the help!

No problem! Have a good time playing with your new board!